summaryrefslogtreecommitdiff
path: root/app-crypt/gpgme/gpgme-1.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
commita8b0d35ab742f31538d515dea39716e566d533c0 (patch)
tree40c6c87a13f0e5ef1111ed1bdd9191f3bd1c1e59 /app-crypt/gpgme/gpgme-1.10.0.ebuild
parent8fcdcec5fbdd0e3a77391e4f354218014f59f358 (diff)
gentoo resync : 06.01.2018
Diffstat (limited to 'app-crypt/gpgme/gpgme-1.10.0.ebuild')
-rw-r--r--app-crypt/gpgme/gpgme-1.10.0.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/app-crypt/gpgme/gpgme-1.10.0.ebuild b/app-crypt/gpgme/gpgme-1.10.0.ebuild
index 941565550cdf..81ca9ecddb2f 100644
--- a/app-crypt/gpgme/gpgme-1.10.0.ebuild
+++ b/app-crypt/gpgme/gpgme-1.10.0.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2.1"
SLOT="1/11" # subslot = soname major version
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="common-lisp static-libs cxx python qt5"
COMMON_DEPEND=">=app-crypt/gnupg-2
@@ -44,6 +44,13 @@ do_python() {
fi
}
+pkg_pretend() {
+ local MAX_WORKDIR=66
+
+ [[ "${#WORKDIR}" -le "${MAX_WORKDIR}" ]] ||
+ die "Cannot build package as WORKDIR '${WORKDIR}' is longer than ${MAX_WORKDIR} which will fail build"
+}
+
pkg_setup() {
addpredict /run/user/$(id -u)/gnupg
}
@@ -51,10 +58,10 @@ pkg_setup() {
src_prepare() {
default
- # Fix too long socket path for gpg-agent, this is mainly a problem
- # for Prefix, where the builddir is deeper in the FS tree.
- sed -i -e '/GNUPGHOME/s:$(abs_builddir):'"${T}"':' \
- tests/gpg/Makefile.{am,in} || die
+ # Make best effort to allow longer PORTAGE_TMPDIR
+ # as usock limitation fails build/tests
+ ln -s "${P}" "${WORKDIR}/b"
+ S="${WORKDIR}/b"
}
src_configure() {