summaryrefslogtreecommitdiff
path: root/app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild')
-rw-r--r--app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild b/app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild
new file mode 100644
index 000000000000..124c3167bb57
--- /dev/null
+++ b/app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+DESCRIPTION="GPG Keyring Manager to handle large GPG keyrings more easily"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha hppa amd64"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ >=app-crypt/gnupg-1.2.1"
+
+src_unpack() {
+ mkdir ${P}
+ cp "${DISTDIR}"/${PN} "${S}" || die
+}
+
+src_compile() {
+ pod2man "${S}"/${PN} >"${S}/"${PN}.1
+ pod2html "${S}"/${PN} >"${S}"/${PN}.html
+}
+
+src_install() {
+ dobin ${PN} || die
+ doman ${PN}.1
+ dohtml ${PN}.html
+}