summaryrefslogtreecommitdiff
path: root/app-crypt/gkeys-gen
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/gkeys-gen
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/gkeys-gen')
-rw-r--r--app-crypt/gkeys-gen/Manifest4
-rw-r--r--app-crypt/gkeys-gen/gkeys-gen-0.2.ebuild39
-rw-r--r--app-crypt/gkeys-gen/gkeys-gen-9999.ebuild56
-rw-r--r--app-crypt/gkeys-gen/metadata.xml8
4 files changed, 107 insertions, 0 deletions
diff --git a/app-crypt/gkeys-gen/Manifest b/app-crypt/gkeys-gen/Manifest
new file mode 100644
index 000000000000..aa46a0446a01
--- /dev/null
+++ b/app-crypt/gkeys-gen/Manifest
@@ -0,0 +1,4 @@
+DIST gkeys-gen-0.2.tar.bz2 19160 BLAKE2B db8ab42b7001cc9189a34291bb22f36344dd1d5a74030269e4675cde83c511cf497f412e8194564c945e322adac421d79441a3914520ee0af39725f4162db65a SHA512 ca46d8cc32f80ac98dfafc0b6ab3e543dc0cb4ee6db2938917d4c6f4fada980996e1ddd48f3ffe563893b973b5763e7016a66f67d4a2f8eb57ee227b1e71a1c2
+EBUILD gkeys-gen-0.2.ebuild 1079 BLAKE2B c6c69e80abf52bcba0aa4e2a847469b71a77c88cc5922c9d8a183ffdf00e4a0d559efb36ad618bda2439d55b1eb0a3082d1a14870c0c9b2749832d083143fb2b SHA512 6d54c3cd59f2e6611560618a4c882f0f3ef8b0089ab177a333ebb3489b3232a673d9b5a71409c1e2812b7fb88dcb3ae7f5d5d994be867938402be326f000c3cc
+EBUILD gkeys-gen-9999.ebuild 1463 BLAKE2B 4e8e5dcaad669a3120fb00303b6b25fb3fe9b057cabba41c81e5cba32ab6fcf0dc926e6f484ac1389bf584af067417f711941d21d52f41c9cdf87f7129895afc SHA512 346dd2dff96e942a89ba549509465ace606421a427593075500f02cc3cf98b158cc1148dd6d919432c9a52931f910f82799f0c8b51cd23a22d9ee450e07ae6cb
+MISC metadata.xml 257 BLAKE2B cf62bcaddae6a9a234fa866aa93f3f8435bc640ded3947993321f8a85e622a2cc0d3df0290bec76b227a4286544314e6a31dc37026482541b4922d6dc11d174a SHA512 62e56bca988936416042bb794e7c8dad9930a46c1f81f51c60a22f3f43e2d0babaacdbef430a6f8ecc8ea7d949effa6136b6d066dabb0a80fde55c36ea3c080c
diff --git a/app-crypt/gkeys-gen/gkeys-gen-0.2.ebuild b/app-crypt/gkeys-gen/gkeys-gen-0.2.ebuild
new file mode 100644
index 000000000000..b6b52f863d31
--- /dev/null
+++ b/app-crypt/gkeys-gen/gkeys-gen-0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+inherit distutils-r1
+
+DESCRIPTION="Tool for generating OpenPGP/GPG keys using a specifications file"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Gentoo-keys"
+SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ dev-python/snakeoil[${PYTHON_USEDEP}]
+ dev-python/pygpgme[${PYTHON_USEDEP}]
+ =app-crypt/gkeys-0.2*[${PYTHON_USEDEP}]
+ "
+
+pkg_postinst() {
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://bugs.gentoo.org"
+ einfo "We are also on IRC @ #gentoo-keys of the Freenode network"
+ einfo
+ ewarn "There may be some Python 3 compatibility issues still."
+ ewarn "Please help us debug, fix and report them in Bugzilla."
+}
diff --git a/app-crypt/gkeys-gen/gkeys-gen-9999.ebuild b/app-crypt/gkeys-gen/gkeys-gen-9999.ebuild
new file mode 100644
index 000000000000..e72ae2a0bd3a
--- /dev/null
+++ b/app-crypt/gkeys-gen/gkeys-gen-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+EGIT_BRANCH="master"
+#EGIT_BRANCH="gen-update"
+
+inherit distutils-r1 git-r3
+
+EGIT_REPO_URI="git://anongit.gentoo.org/proj/gentoo-keys.git"
+#EGIT_REPO_URI="https://github.com/gentoo/gentoo-keys.git"
+
+DESCRIPTION="Tool for generating OpenPGP/GPG keys using a specifications file"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Gentoo-keys"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ dev-python/snakeoil[${PYTHON_USEDEP}]
+ dev-python/pygpgme[${PYTHON_USEDEP}]
+ =app-crypt/gkeys-9999[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/$P/gkeys-gen"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ # copy these 2 into our subdir from the master level
+ cp ../LICENSE ./ || die "cp LICENSE failed"
+ cp ../README.md ./ || die "cp README.me failed"
+ cp -R ../py2man ./ || die "cp-R py2man failed"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://bugs.gentoo.org"
+ einfo "We are also on IRC @ #gentoo-keys of the freenode network"
+ einfo
+ ewarn "There may be some python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in bugzilla."
+}
diff --git a/app-crypt/gkeys-gen/metadata.xml b/app-crypt/gkeys-gen/metadata.xml
new file mode 100644
index 000000000000..1937e8c82b4b
--- /dev/null
+++ b/app-crypt/gkeys-gen/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gkeys@gentoo.org</email>
+ <name>Gentoo-keys Project Team</name>
+ </maintainer>
+</pkgmetadata>