summaryrefslogtreecommitdiff
path: root/app-crypt/debian-archive-keyring/debian-archive-keyring-2023.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-18 18:31:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-18 18:31:43 +0000
commitcd0d9000770337b445051f1852fe3971ceb7a6e2 (patch)
tree49c82dbb14c2d960e04e7482bdefe6ed2d53a173 /app-crypt/debian-archive-keyring/debian-archive-keyring-2023.2.ebuild
parent12c505f7fcc9ddc89e96ed178df05aceec162d92 (diff)
gentoo auto-resync : 18:03:2023 - 18:31:42
Diffstat (limited to 'app-crypt/debian-archive-keyring/debian-archive-keyring-2023.2.ebuild')
-rw-r--r--app-crypt/debian-archive-keyring/debian-archive-keyring-2023.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-crypt/debian-archive-keyring/debian-archive-keyring-2023.2.ebuild b/app-crypt/debian-archive-keyring/debian-archive-keyring-2023.2.ebuild
new file mode 100644
index 000000000000..00b2e3a5b143
--- /dev/null
+++ b/app-crypt/debian-archive-keyring/debian-archive-keyring-2023.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="GnuPG archive keys of the Debian archive"
+HOMEPAGE="https://packages.debian.org/sid/debian-archive-keyring"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}_all.deb"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_install() {
+ doins -r .
+
+ # https://bugs.gentoo.org/729142
+ gunzip "${D}"/usr/share/doc/${PN}/changelog.gz || die
+
+ mv "${D}"/usr/share/doc/{${PN},${PF}} || die
+}