summaryrefslogtreecommitdiff
path: root/app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild')
-rw-r--r--app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild b/app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild
new file mode 100644
index 000000000000..bbf259a150b6
--- /dev/null
+++ b/app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+DESCRIPTION="GnuPG archive keys of the Debian archive"
+HOMEPAGE="https://packages.debian.org/sid/debian-archive-keyring"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}_all.deb"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_install() {
+ doins -r .
+
+ # https://bugs.gentoo.org/729142
+ gunzip "${D}"/usr/share/doc/${PN}/changelog.gz || die
+
+ mv "${D}"/usr/share/doc/{${PN},${PF}} || die
+}