summaryrefslogtreecommitdiff
path: root/app-crypt/codecrypt/codecrypt-1.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /app-crypt/codecrypt/codecrypt-1.8-r1.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'app-crypt/codecrypt/codecrypt-1.8-r1.ebuild')
-rw-r--r--app-crypt/codecrypt/codecrypt-1.8-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/codecrypt/codecrypt-1.8-r1.ebuild b/app-crypt/codecrypt/codecrypt-1.8-r1.ebuild
new file mode 100644
index 000000000000..effd43182526
--- /dev/null
+++ b/app-crypt/codecrypt/codecrypt-1.8-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Post-quantum cryptography tool"
+HOMEPAGE="http://e-x-a.org/codecrypt/"
+SRC_URI="http://e-x-a.org/codecrypt/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+cryptopp"
+
+DEPEND="dev-libs/gmp:=
+ cryptopp? ( >=dev-libs/crypto++-7 )
+ sci-libs/fftw:3.0"
+RDEPEND="${DEPEND}"
+src_prepare() {
+ default
+ # workaround -- the library renamed the pkg-config file
+ sed -i -e 's/PKG_CHECK_MODULES(\[CRYPTOPP\],.*/PKG_CHECK_MODULES([CRYPTOPP], [libcryptopp])/' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with cryptopp )
+}