summaryrefslogtreecommitdiff
path: root/app-crypt/certbot-dns-nsone/certbot-dns-nsone-0.39.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /app-crypt/certbot-dns-nsone/certbot-dns-nsone-0.39.0-r1.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'app-crypt/certbot-dns-nsone/certbot-dns-nsone-0.39.0-r1.ebuild')
-rw-r--r--app-crypt/certbot-dns-nsone/certbot-dns-nsone-0.39.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/certbot-dns-nsone/certbot-dns-nsone-0.39.0-r1.ebuild b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-0.39.0-r1.ebuild
new file mode 100644
index 000000000000..221d334e171b
--- /dev/null
+++ b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-0.39.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python3_6 python3_7)
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/certbot-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="NS1 DNS Authenticator plugin for Certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=app-crypt/certbot-0.31.0[${PYTHON_USEDEP}]
+ >=app-crypt/acme-0.39.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ >=dev-python/dns-lexicon-2.2.1[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"