summaryrefslogtreecommitdiff
path: root/app-crypt/bsign/bsign-0.4.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/bsign/bsign-0.4.5-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/bsign/bsign-0.4.5-r1.ebuild')
-rw-r--r--app-crypt/bsign/bsign-0.4.5-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-crypt/bsign/bsign-0.4.5-r1.ebuild b/app-crypt/bsign/bsign-0.4.5-r1.ebuild
new file mode 100644
index 000000000000..11ef50052dbb
--- /dev/null
+++ b/app-crypt/bsign/bsign-0.4.5-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic
+
+DESCRIPTION="embed secure hashes (SHA1) and digital signatures (GNU Privacy Guard) into files"
+HOMEPAGE="http://packages.debian.org/sid/bsign"
+SRC_URI="mirror://debian/pool/main/b/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc ~x86 ~x86-linux ~ppc-macos"
+IUSE="static-libs"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-non-gnu.patch # for Darwin, BSD, Solaris, etc.
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-scripts.patch
+)
+
+src_prepare() {
+ default
+ mv configure.in configure.ac
+ eautoreconf
+}
+
+src_configure() {
+ use static-libs && append-ldflags -static
+ default
+}
+
+src_install() {
+ einstalldocs
+ dobin bsign_sign bsign_verify bsign_hash bsign_check
+ newbin o/bsign-unstripped bsign
+ doman bsign.1
+}