summaryrefslogtreecommitdiff
path: root/app-crypt/age/age-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-27 14:10:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-27 14:10:06 +0000
commit4429be000a778f363162554d59d903a725283d7d (patch)
tree16a6de16cbef2e9dcb36233f2e0c825f3ff60493 /app-crypt/age/age-1.1.1.ebuild
parent2d9c9c77c273a982d69ad4caefcc1a3783844056 (diff)
gentoo auto-resync : 27:12:2022 - 14:10:05
Diffstat (limited to 'app-crypt/age/age-1.1.1.ebuild')
-rw-r--r--app-crypt/age/age-1.1.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/age/age-1.1.1.ebuild b/app-crypt/age/age-1.1.1.ebuild
new file mode 100644
index 000000000000..38d405360142
--- /dev/null
+++ b/app-crypt/age/age-1.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="A simple, modern and secure encryption tool (and Go library)"
+HOMEPAGE="https://github.com/FiloSottile/age"
+SRC_URI="https://github.com/FiloSottile/age/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~graaff/age/${P}-deps.tar.xz"
+
+S="${WORKDIR}/age-${PV}"
+
+LICENSE="BSD"
+#RESTRICT+=" test"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-go/gox"
+
+src_compile() {
+ go build -ldflags "-X main.Version=${PV}" -o . filippo.io/age/cmd/... || die
+}
+
+src_test() {
+ go test -race filippo.io/age/cmd/... || die
+}
+
+src_install() {
+ dobin age age-keygen
+ doman doc/age.1 doc/age-keygen.1
+ dodoc README.md
+}