summaryrefslogtreecommitdiff
path: root/app-crypt/aespipe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /app-crypt/aespipe
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'app-crypt/aespipe')
-rw-r--r--app-crypt/aespipe/Manifest4
-rw-r--r--app-crypt/aespipe/aespipe-2.4f.ebuild27
-rw-r--r--app-crypt/aespipe/metadata.xml9
3 files changed, 38 insertions, 2 deletions
diff --git a/app-crypt/aespipe/Manifest b/app-crypt/aespipe/Manifest
index fcfda96aa83f..d5d5be0ca14b 100644
--- a/app-crypt/aespipe/Manifest
+++ b/app-crypt/aespipe/Manifest
@@ -1,3 +1,5 @@
DIST aespipe-v2.4e.tar.bz2 107741 BLAKE2B 9331441214b495f042f8ac41b57203057e762156aa7b6bd9fcb8d55b3e149fb79dd0d7c06358599fefd6662d797baf4cf9ba84fc4425e637c9fef0abf1b254c7 SHA512 e038f710ac971e5ba740648c0f255e8bc9fcea9be1a6b76208a453f21f013e1662c006d4f4495fa2b2560fd9b0c236947462a9b337a120073c6a5335b29f077e
+DIST aespipe-v2.4f.tar.bz2 107663 BLAKE2B 80af945ec938307ddaeb1a1f7a91da71d4f1aeabe4cb303166cad95c36e0d0090fd8440bb636ac0245d2701d61fdea715c84e18dfacf32bfba7f4b85a2db091f SHA512 75b6b2069a0e013dbded29b07b990fc783cc04ce05fc37e6591dae7e8190485960735ec1a1af18d065be57d0b7ec23dbe520e920f92e9c01170b7a23eb32eb3f
EBUILD aespipe-2.4e.ebuild 749 BLAKE2B f0af3d47dcf8d381891a0711a968a9d75a72136a4b52a8548b6e49d5445b2d49e1a3da595fa6ce18a3cc132ca3c90917a1fdb9440a0508f0c6f7608e6b53c222 SHA512 42d563aeb28a957534b0205aa47df96440cde79baad55b2848f9d1d7aa2fccece4d3abb06e070322016def375c8f9b3ddcb23eda7a75a1e93704d534007e6b25
-MISC metadata.xml 451 BLAKE2B c23c4255b9480af40363c626a009f59e331a7382c48ddcd54be624998076c4da02f77105acfa6b9ba590d04f9bc338ae9d2ab70a98ff8ec7597dc75b4a83ea1e SHA512 a95dcbd4c3e796d7a9fc2b5d1f4ba17e5a0be6a24318b970cdc4498a44c279fc05ef20097477bd44fcd4eefe03be2545d439966ecb88d6be4cb9c824bda19a1b
+EBUILD aespipe-2.4f.ebuild 743 BLAKE2B a6885af52b99c1f95197da318ee3c2942c179970049a745613bb78513de8f531a2a77e24c932da80fa1c22628bc72042d1153f99648437ad14c32732b4e9e7d0 SHA512 b0fad08d2d21417df8161f4e1a1c85273f4a06fd548f5eb1b2b17bab81028328483d6d82a71b39b43da94818a757209d264ceee2d8ec481acc36015bd2b14983
+MISC metadata.xml 650 BLAKE2B 4bf3cde201df3b0cd6d73e56b3502946c117d8942853ef1e919c245cde0b7f19da7a4cf6e5f95467f8235b6b3033d4897844c6142b9facb0836c92283d81d156 SHA512 73da723df8d56d8a2030bab56d830473fa66dda7f91e62f251c09db6164413dcc6c1f9c160586e383f4874aba11d21e57c44df21dedcf591d378196736136378
diff --git a/app-crypt/aespipe/aespipe-2.4f.ebuild b/app-crypt/aespipe/aespipe-2.4f.ebuild
new file mode 100644
index 000000000000..3ead8cc5fb4e
--- /dev/null
+++ b/app-crypt/aespipe/aespipe-2.4f.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Encrypts data from stdin to stdout"
+HOMEPAGE="http://loop-aes.sourceforge.net"
+SRC_URI="http://loop-aes.sourceforge.net/aespipe/${PN}-v${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="+asm cpu_flags_x86_aes cpu_flags_x86_padlock static"
+RDEPEND="app-arch/sharutils
+ app-crypt/gnupg"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ $(use_enable asm) \
+ $(use_enable cpu_flags_x86_aes intelaes) \
+ $(use_enable cpu_flags_x86_padlock padlock)
+}
diff --git a/app-crypt/aespipe/metadata.xml b/app-crypt/aespipe/metadata.xml
index cc185eaa435c..c896699a412e 100644
--- a/app-crypt/aespipe/metadata.xml
+++ b/app-crypt/aespipe/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>hlein@korelogic.com</email>
+ <name>Hank Leininger</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<use>
<flag name="asm">Enable assembly modules</flag>
<flag name="cpu_flags_x86_padlock">Use VIA padlock instructions,