summaryrefslogtreecommitdiff
path: root/app-crypt/aescrypt/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /app-crypt/aescrypt/files
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'app-crypt/aescrypt/files')
-rw-r--r--app-crypt/aescrypt/files/aescrypt-3.14-ldflags.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-crypt/aescrypt/files/aescrypt-3.14-ldflags.patch b/app-crypt/aescrypt/files/aescrypt-3.14-ldflags.patch
new file mode 100644
index 000000000000..757f0e4e7fcb
--- /dev/null
+++ b/app-crypt/aescrypt/files/aescrypt-3.14-ldflags.patch
@@ -0,0 +1,20 @@
+diff -Naru a/src/Makefile b/src/Makefile
+--- a/src/Makefile 2021-07-14 09:25:15.509797042 +0200
++++ b/src/Makefile 2021-07-14 09:25:46.689797121 +0200
+@@ -27,13 +27,13 @@
+ all: aescrypt aescrypt_keygen
+
+ aescrypt: $(AESCRYPT_OBJS)
+- $(CC) $(CFLAGS) $(LIBS) -o $@ $(AESCRYPT_OBJS)
++ $(CC) $(CFLAGS) $(LIBS) $(LDFLAGS) -o $@ $(AESCRYPT_OBJS)
+
+ aescrypt_keygen: $(KEYGEN_OBJS)
+- $(CC) $(CFLAGS) $(LIBS) -o $@ $(KEYGEN_OBJS)
++ $(CC) $(CFLAGS) $(LIBS) $(LDFLAGS) -o $@ $(KEYGEN_OBJS)
+
+ %.o: %.c %.h
+- $(CC) $(CFLAGS) -c $*.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -c $*.c
+
+ install: aescrypt
+ install -o root -g root -m 755 aescrypt /usr/bin