summaryrefslogtreecommitdiff
path: root/app-crypt/acme-tiny
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-crypt/acme-tiny
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-crypt/acme-tiny')
-rw-r--r--app-crypt/acme-tiny/Manifest4
-rw-r--r--app-crypt/acme-tiny/acme-tiny-5.0.1.ebuild47
-rw-r--r--app-crypt/acme-tiny/acme-tiny-9999.ebuild4
3 files changed, 52 insertions, 3 deletions
diff --git a/app-crypt/acme-tiny/Manifest b/app-crypt/acme-tiny/Manifest
index 5be973824902..d2bba176d7a1 100644
--- a/app-crypt/acme-tiny/Manifest
+++ b/app-crypt/acme-tiny/Manifest
@@ -1,4 +1,6 @@
DIST acme-tiny-4.1.0.tar.gz 12776 BLAKE2B 7efd9d1399ec3bbd98180511c9f36fbf6f9a96a0d4e0e72b9d4c85d16246118eaaad25bc26ba42f746fd4b60b498ceca5307e279d788157237ac6ad153848501 SHA512 31d69a5031c019acbc23b3f06041eae8e261766396d4a7420fd70a71cfa16de953bea4c0c2ad0c6a6e793ed61ab5331f40145352ffce69f4f062f35dd0db7519
+DIST acme-tiny-5.0.1.tar.gz 21036 BLAKE2B a09c16ca19570b48d34c919e2a361e3be5d66ed8fc0ccff7af74e4018d294f2940a552906dee45bac27a16e7b039a3567dc35e201b058015c5123baa2cbb01c1 SHA512 6e0619917b31a5795c2c7d8aa811b46231b81fc6b57227f611f7f4b9f73eb3de669676482563c33d935a4a0812498677bcbe974663a561af61abb441a880947e
EBUILD acme-tiny-4.1.0.ebuild 1108 BLAKE2B fe306b726c732ca03b672bc2cb7668b1125868daf5758b69312ca27e4ea71a3374b9d3ac00cebfe4459c566b68ee5fd807bf3cac1a44f64dd70afb2789a7c783 SHA512 bda714125cad2d2442539691630caf3de45498e0ac6a6e95211ec0e2e3a4fefc4a3d7b2c221359a7ac0b86a7d0126e361604dfb3c8a677b2c026b3fac61016fc
-EBUILD acme-tiny-9999.ebuild 1110 BLAKE2B 15dd4d5adf387cb805ca3b35bc31cb4ea3bb36a7835ddaa090126e3fbe229e0db9cb6ea251bb0fd00b7ddce9413809d4fe080b97bded7350b81988f1433c2cf2 SHA512 71e613afa351a85093024e09ef945b118479f0c1b74516642f7d866f454eecd24a2dde87afd36de6894fb66b1f4f339514acbe3439e8cad819abd3d87da57043
+EBUILD acme-tiny-5.0.1.ebuild 1115 BLAKE2B ad6d68f9de100b37eadad44105a8d541373663f97f233a1620cebf2055e97f1be701220a772e8fb92a24e69355f8c7f7fb97213c374abecf7869b9ce6b00dcfa SHA512 23a05a75412e621c550cea4ace83c98b5e4b41c76b988cc3c93899ead5de63fdd7e4b57749d0ffd8fe1e692d7985c70284718c64b44283349c7858cdaabca74a
+EBUILD acme-tiny-9999.ebuild 1115 BLAKE2B ad6d68f9de100b37eadad44105a8d541373663f97f233a1620cebf2055e97f1be701220a772e8fb92a24e69355f8c7f7fb97213c374abecf7869b9ce6b00dcfa SHA512 23a05a75412e621c550cea4ace83c98b5e4b41c76b988cc3c93899ead5de63fdd7e4b57749d0ffd8fe1e692d7985c70284718c64b44283349c7858cdaabca74a
MISC metadata.xml 332 BLAKE2B e5e439ca9e8a4809dc6d76d879d1d0708475d59c39c47724e2fd1375bb0026fc6d470c893abc02a5d0d2f06e0538ae024265cbd76c056d87375db02867512684 SHA512 36f47d97f15ef341b5ae81d23e85d94cf02ce71d6a20b7bdcdc16ef0c36a091c99e09ebe86f05aac789a36f1dcd71819832b53a4d835a1a12cd468e1b3f132e5
diff --git a/app-crypt/acme-tiny/acme-tiny-5.0.1.ebuild b/app-crypt/acme-tiny/acme-tiny-5.0.1.ebuild
new file mode 100644
index 000000000000..b1ca9c31e4af
--- /dev/null
+++ b/app-crypt/acme-tiny/acme-tiny-5.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8,3_9,3_10} )
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/diafygi/${PN}.git"
+else
+ SRC_URI="https://github.com/diafygi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A tiny, auditable script for Let's Encrypt's ACME Protocol"
+HOMEPAGE="https://github.com/diafygi/acme-tiny"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+RDEPEND="dev-libs/openssl:0"
+
+pkg_setup() {
+ if [[ ${PV} != 9999 ]]; then
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+ fi
+}
+
+src_prepare() {
+ sed -i 's|#!/usr/bin/sh|#!/bin/sh|g' README.md || die
+
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "$v" "-lt" "4.0.3" || ver_test "$v" "-ge" "9999"; then
+ einfo "The --account-email flag has been changed to --contact and"
+ einfo "has different syntax."
+ einfo "Please update your scripts accordingly"
+ fi
+ done
+}
diff --git a/app-crypt/acme-tiny/acme-tiny-9999.ebuild b/app-crypt/acme-tiny/acme-tiny-9999.ebuild
index 5c6c1c7e6e6b..b1ca9c31e4af 100644
--- a/app-crypt/acme-tiny/acme-tiny-9999.ebuild
+++ b/app-crypt/acme-tiny/acme-tiny-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8,3_9} )
+PYTHON_COMPAT=( python{3_7,3_8,3_9,3_10} )
inherit distutils-r1
if [[ ${PV} == 9999 ]]; then