summaryrefslogtreecommitdiff
path: root/app-crypt/acme-sh/acme-sh-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /app-crypt/acme-sh/acme-sh-9999.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'app-crypt/acme-sh/acme-sh-9999.ebuild')
-rw-r--r--app-crypt/acme-sh/acme-sh-9999.ebuild51
1 files changed, 27 insertions, 24 deletions
diff --git a/app-crypt/acme-sh/acme-sh-9999.ebuild b/app-crypt/acme-sh/acme-sh-9999.ebuild
index 7ff01d8cd7e6..1e6ca0155893 100644
--- a/app-crypt/acme-sh/acme-sh-9999.ebuild
+++ b/app-crypt/acme-sh/acme-sh-9999.ebuild
@@ -1,45 +1,48 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-EGIT_REPO_URI="https://github.com/Neilpang/${PN/-/.}.git"
+inherit git-r3 optfeature
-inherit git-r3
-
-DESCRIPTION="An ACME Shell script"
-HOMEPAGE="https://github.com/Neilpang/acme.sh"
-SRC_URI=""
+DESCRIPTION="A pure Unix shell script implementing ACME client protocol"
+HOMEPAGE="https://github.com/acmesh-official/acme.sh"
+EGIT_REPO_URI="https://github.com/acmesh-official/${PN/-/.}.git"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE=""
-RDEPEND="net-misc/curl
- || ( dev-libs/libressl dev-libs/openssl:0 )
- || ( net-analyzer/netcat net-analyzer/openbsd-netcat )
- || ( net-misc/socat www-servers/apache:2 www-servers/nginx )
- virtual/cron"
+RDEPEND="
+ dev-libs/openssl:0
+ net-misc/curl
+ net-misc/socat
+"
src_install() {
- einstalldocs
- newdoc dnsapi/README.md README-dnsapi.md
newdoc deploy/README.md README-deploy.md
+ newdoc dnsapi/README.md README-dnsapi.md
+ rm {deploy,dnsapi}/README.md || die
+ einstalldocs
+
+ exeinto /usr/share/acme.sh
+ doexe acme.sh
+
+ insinto /usr/share/acme.sh
+ doins -r deploy dnsapi notify
keepdir /etc/acme-sh
doenvd "${FILESDIR}"/99acme-sh
+
insinto /etc/bash/bashrc.d
doins "${FILESDIR}"/acme.sh
- exeinto /usr/share/acme.sh
- doexe acme.sh
- insinto /usr/share/acme.sh/dnsapi
- doins -r dnsapi/*.sh
- insinto /usr/share/acme.sh/deploy
- doins -r deploy/*.sh
- insinto /usr/share/acme.sh/notify
- doins -r notify/*.sh
-
dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
}
+
+pkg_postinst() {
+ einfo "If you wish to use the webserver mode,"
+ einfo "you need to install a supported web server."
+ optfeature "using apache2 webserver mode." www-servers/apache
+ optfeature "using nginx webserver mode." www-servers/nginx
+}