summaryrefslogtreecommitdiff
path: root/app-containers/skopeo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-01 23:01:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-01 23:01:08 +0000
commitb0632f33a9a34123e027e91c44916235a5cd9494 (patch)
treec5f561876ec5641cc9b198262d4da3c91ef6b120 /app-containers/skopeo
parentb704a12f55494cd0f6fef2a547cab684dcecd4de (diff)
gentoo auto-resync : 01:12:2023 - 23:01:08
Diffstat (limited to 'app-containers/skopeo')
-rw-r--r--app-containers/skopeo/Manifest1
-rw-r--r--app-containers/skopeo/skopeo-1.14.0-r2.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-containers/skopeo/Manifest b/app-containers/skopeo/Manifest
index dcf0ce05c44f..e843bf11e00a 100644
--- a/app-containers/skopeo/Manifest
+++ b/app-containers/skopeo/Manifest
@@ -6,6 +6,7 @@ DIST skopeo-1.5.1.tar.gz 5636533 BLAKE2B 7f0e86cdee5c3250ec1280d7e71554ac2f8ad96
EBUILD skopeo-1.10.0-r1.ebuild 1066 BLAKE2B f55aa099a396fca1f8513786c48929923d7419a08d232ba910d65d325c5f31c2a4fbb43487d3585c36098375687897f07fbd9e7274edeb4e1b7bf5301dba040d SHA512 0109637023cf52163bbdc2a30fbd086f514a5bd77948888ce30a7824cf4472c46f98f6011e9a0302a054578e5bb812d2b495dac041a060bdb26abbbd034c27bc
EBUILD skopeo-1.11.1.ebuild 1066 BLAKE2B d304dfa99199b32528a24710a716ab757f9670e4b474fd48c5284005a0a01cc457af1d3882572f27aa81eadb058ec495c7dcebf775dec238ae4b44f0d748d0d0 SHA512 14ad618519d078c4f539afdc3595bd80a1fd102e21abd231f71a530de5019557d915a6809ce1cecb7dc1ee6be57ee9a5b12add0fee1fc8d7325fc2f1f567896b
EBUILD skopeo-1.14.0-r1.ebuild 2097 BLAKE2B 4f25431121f91ecf094f74820c9a948252ecaaa611b824e8b2dcdc6452a3c4de67c0f9dee07585f15cd6c57bb98aae661618f4cbf017b13160161cceb4143030 SHA512 428330a458080957266cc56f9214e25b08f964c20e33534b771a1f83e9812aca5d2d5703991a089258ab035192939669efb9103c88d8aebc7278dc8ac257c328
+EBUILD skopeo-1.14.0-r2.ebuild 1805 BLAKE2B e6dab376de81f00b115c71d60da9a8e50734aad8872fdf4345ace367a7df0d3dc284348406615f0e39f3fbd6bf9421f5fd426e3cb06d82bd4725bee0f20eb8db SHA512 ec0785aab60132debdb29bfdce1ec6354f19724893bb619b627cf6c0e1ebdc56ba574cfc8ff7ffb1b57cb5e96414d95531e6314566de1673e549ccfda0cd42c1
EBUILD skopeo-1.5.1.ebuild 1403 BLAKE2B a4c236cb6248a1551c90683a45247d19d5634ca7e9ca801761953131f73a7bd0058ab5bcea1d7b2593229eb20c6482e2dae833443227467daccef020b23b5f88 SHA512 b163486639a8831eb20db3a5906378485f0aaf3299e815217b1c8a2f4e27ca35af0bda40e6265a7c58107588cab429c0044717666cd22c43e8e21c73a75277dd
EBUILD skopeo-9999.ebuild 2097 BLAKE2B 4f25431121f91ecf094f74820c9a948252ecaaa611b824e8b2dcdc6452a3c4de67c0f9dee07585f15cd6c57bb98aae661618f4cbf017b13160161cceb4143030 SHA512 428330a458080957266cc56f9214e25b08f964c20e33534b771a1f83e9812aca5d2d5703991a089258ab035192939669efb9103c88d8aebc7278dc8ac257c328
MISC metadata.xml 932 BLAKE2B 07a3c417bf16785676ad46085fd30feef0bb9970157a34a48b5f633878633788de20da8d9d24b14b356ff19bd7012ceeb9ace0aee84dcece374dd609a14d9ce3 SHA512 33a8355d730bf0f6f53f77ef2a1d0cb5a3a3e9f4b9bb76603e2da9fa087e9065b6bf950170cdb3b194105a24e34ab98e006880b3ac9d737152a4d309ec4d0fe7
diff --git a/app-containers/skopeo/skopeo-1.14.0-r2.ebuild b/app-containers/skopeo/skopeo-1.14.0-r2.ebuild
new file mode 100644
index 000000000000..2aed06a521af
--- /dev/null
+++ b/app-containers/skopeo/skopeo-1.14.0-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module linux-info
+
+DESCRIPTION="Work with remote container images registries"
+HOMEPAGE="https://github.com/containers/skopeo"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/skopeo.git"
+else
+ SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+# main
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
+SLOT="0"
+IUSE="btrfs device-mapper rootless"
+
+COMMON_DEPEND="
+ >=app-crypt/gpgme-1.5.5:=
+ >=dev-libs/libassuan-2.4.3:=
+ btrfs? ( >=sys-fs/btrfs-progs-4.0.1 )
+ device-mapper? ( >=sys-fs/lvm2-2.02.145:= )
+ rootless? ( sys-apps/shadow:= )
+"
+
+# TODO: Is this really needed? cause upstream doesnt mention it https://github.com/containers/skopeo/blob/main/install.md#building-from-source
+# dev-libs/libgpg-error:=
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="
+ ${COMMON_DEPEND}
+ app-containers/containers-common
+"
+BDEPEND="dev-go/go-md2man"
+
+RESTRICT="test"
+
+pkg_setup() {
+ use btrfs && CONFIG_CHECK+=" ~BTRFS_FS"
+ use device-mapper && CONFIG_CHECK+=" ~MD"
+ linux-info_pkg_setup
+}
+
+run_make() {
+ emake \
+ BTRFS_BUILD_TAG="$(usex btrfs '' 'btrfs_noversion exclude_graphdriver_btrfs')" \
+ CONTAINERSCONFDIR="${EPREFIX}/etc/containers" \
+ LIBDM_BUILD_TAG=$(usex device-mapper '' libdm_no_deferred_remove) \
+ LIBSUBID_BUILD_TAG=$(usex rootless 'libsubid' '') \
+ PREFIX="${EPREFIX}/usr" \
+ $@
+}
+
+src_compile() {
+ run_make all completions
+}
+
+src_install() {
+ # The install target in the Makefile tries to rebuild the binary and
+ # installs things that are already installed by containers-common.
+ dobin bin/skopeo
+dodoc README.md
+ doman docs/*.1
+ run_make "DESTDIR=${D}" install-completions
+}