summaryrefslogtreecommitdiff
path: root/app-containers/netavark/netavark-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-29 10:51:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-29 10:51:05 +0000
commit65277f763adcb68cea58abf75cd35eab450a0d15 (patch)
treeecbede5e2e057a3fcd5c996882354ad5f400c119 /app-containers/netavark/netavark-9999.ebuild
parentb20b0e862d577cc2f56ed09f5f833a80fd839d38 (diff)
gentoo auto-resync : 29:11:2023 - 10:51:05
Diffstat (limited to 'app-containers/netavark/netavark-9999.ebuild')
-rw-r--r--app-containers/netavark/netavark-9999.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/app-containers/netavark/netavark-9999.ebuild b/app-containers/netavark/netavark-9999.ebuild
index 7cb769c2a876..31531a21ec6e 100644
--- a/app-containers/netavark/netavark-9999.ebuild
+++ b/app-containers/netavark/netavark-9999.ebuild
@@ -3,20 +3,25 @@
EAPI=8
-[[ ${PV} == *9999* ]] || CRATES="${PN}@${PV}"
+[[ ${PV} == 9999* ]] || CRATES="${PN}@${PV}"
inherit cargo systemd
DESCRIPTION="A container network stack"
HOMEPAGE="https://github.com/containers/netavark"
-if [[ ${PV} == *9999* ]]; then
+
+if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/containers/netavark.git"
else
SRC_URI="${CARGO_CRATE_URIS} https://github.com/containers/netavark/releases/download/v${PV}/${PN}-v${PV}-vendor.tar.gz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
fi
-LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 MIT Unicode-DFS-2016 Unlicense ZLIB"
+
+# main
+LICENSE="Apache-2.0"
+# deps
+LICENSE+=" Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 MIT Unicode-DFS-2016 Unlicense ZLIB"
SLOT="0"
BDEPEND="dev-go/go-md2man
dev-libs/protobuf"
@@ -29,7 +34,7 @@ QA_PRESTRIPPED="
ECARGO_VENDOR="${WORKDIR}/vendor"
src_unpack() {
- if [[ ${PV} == *9999* ]]; then
+ if [[ ${PV} == 9999* ]]; then
git-r3_src_unpack
cargo_live_src_unpack
else
@@ -48,6 +53,7 @@ src_compile() {
emake docs
}
+# Following is needed because we want to use `make install` instead of `cargo install` (exported by cargo.eclass)
src_install() {
default
}