summaryrefslogtreecommitdiff
path: root/app-containers/nerdctl/nerdctl-1.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-03 21:32:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-03 21:32:31 +0100
commit5043a584ce7a3eb644e68694a3266c1a5d2ccba5 (patch)
tree2401f70bb9284c4237ee848dcb65c610db18a643 /app-containers/nerdctl/nerdctl-1.4.0.ebuild
parentc1503bdaa031111d22d91db2f41dad440fb148e8 (diff)
gentoo auto-resync : 03:06:2023 - 21:32:31
Diffstat (limited to 'app-containers/nerdctl/nerdctl-1.4.0.ebuild')
-rw-r--r--app-containers/nerdctl/nerdctl-1.4.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-containers/nerdctl/nerdctl-1.4.0.ebuild b/app-containers/nerdctl/nerdctl-1.4.0.ebuild
new file mode 100644
index 000000000000..a01a8d688b2f
--- /dev/null
+++ b/app-containers/nerdctl/nerdctl-1.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+EGIT_COMMIT="7e8114a82da342cdbec9a518c5c6a1cce58105e9"
+
+DESCRIPTION="Docker-compatible CLI for containerd, with support for Compose"
+HOMEPAGE="https://github.com/containerd/nerdctl"
+SRC_URI="
+ https://github.com/containerd/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/containerd/${PN}/releases/download/v${PV}/${P}-go-mod-vendor.tar.gz
+"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ cd "${S}"
+ unpack "${P}-go-mod-vendor.tar.gz"
+}
+
+src_compile() {
+ emake VERSION=v${PV} REVISION="${EGIT_COMMIT}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" VERSION=v${PV} REVISION="${EGIT_COMMIT}" BINDIR="/usr/bin" install
+ DOCS=( README.md docs/* examples )
+ einstalldocs
+}