summaryrefslogtreecommitdiff
path: root/app-containers/lxc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-25 14:56:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-25 14:56:29 +0100
commit22899eb46c1c332d9a8a995c0be0b965fb1bcfc3 (patch)
tree25c77db0aa77917e9d02268c57cdd9fac0d82035 /app-containers/lxc
parentbf2c6ad6782df5963101bc3e73c0d31d65e0829f (diff)
gentoo auto-resync : 25:07:2022 - 14:56:29
Diffstat (limited to 'app-containers/lxc')
-rw-r--r--app-containers/lxc/Manifest1
-rw-r--r--app-containers/lxc/lxc-5.0.0-r1.ebuild160
2 files changed, 161 insertions, 0 deletions
diff --git a/app-containers/lxc/Manifest b/app-containers/lxc/Manifest
index 72a6e003f49e..2d81c6673e7f 100644
--- a/app-containers/lxc/Manifest
+++ b/app-containers/lxc/Manifest
@@ -12,5 +12,6 @@ DIST lxc-4.0.12.tar.gz.asc 833 BLAKE2B 2fca60b5ac267a893f70875ccdbe39db6b98b5fe5
DIST lxc-5.0.0.tar.gz 968678 BLAKE2B 82fa15353bdd78a1cc4cdb915f4a8366790b4ac317247bb03ceae91137368ef953ec52f6882ba9d44f6b9bddd3ac20579339e6bbedb4e5642adc81473825a91d SHA512 ecdce46a83602197716c9a4e50e0514a7e0764fbf34db6d5e3497e90669b4c8ced4b787fb220967d95dd8e50016075f3b118e85d9d63c21b2ba17de2e7aefb81
DIST lxc-5.0.0.tar.gz.asc 833 BLAKE2B 3519789f7a9797895c1b89371db28add0833b0db5a32b71f8fdff98f689a2ed6edd77db90fad89658e7c148a94a1008a718dca32bc3ce40dbfce9b44c9506dbd SHA512 d475073543e82481675a4d7ffe642445b73698ad0675cfd996768c6f026786c694cea062d50139264362a516b8777fc4e1a5fb5592eeed35ac2f6d64460c505d
EBUILD lxc-4.0.12.ebuild 5184 BLAKE2B 1c3a59f4bb1b43c66acae7de91014ea3aea152d3595e2e6431f30e56d99a2316b2c1d73bcb975371f84273b88282c22eda1691f798a4d3a373a3873596bfdb74 SHA512 a5435cfc04ead876fe7c3e7931307ebdd18057849e7cfd9e0b18073a5aff73e03e4f3b9f7cbf4efe608f4ba1502dde59195ebde8a6591c566cb2ac16ae1ba456
+EBUILD lxc-5.0.0-r1.ebuild 4765 BLAKE2B 279f77d0ecef7fa2df1fefe0703ed0dda08b17e4accd306b008e4ccfcdd5da4c65923840ba59ba45ccfc1e9ce9a2f3e229bd03a38b5dbc56bcb4042c40db61e3 SHA512 0ebd24bd48d73012bb3488438e3cf5bcc08d7aee31f5cd202a7be8f911be68515cd2f68c23363b505c1f4af4fa42bea536dc8d18864136da08bfa1b0eb01f8e7
EBUILD lxc-5.0.0.ebuild 4742 BLAKE2B abb306e2b67b3bbf4b83b653973e85794b98fdb1502f50a069ca2d76a2a981cdb6c7e761f73039b9734088d630a2f74881c065c040191eb3ff1edd707845d7c6 SHA512 d4bbb6b7a00945a1629ada5bfdd5bd99b08fe008cafac0de56f6f6f0f7ca44126de07aaf18fee3b52d0a2d8367bddcb9a3f0ae19d998c8fb510a8c847b317b2a
MISC metadata.xml 713 BLAKE2B 982d13dbe2adffcdb473804981effa8eabc89ca95dc2f39ae6ebdbdce0f786311333c8f9cbfe2105faf55dcbaf7a63a09b46e6b7c7987ba629f5e87de24a348c SHA512 4c9d018afe1967708c18747f504b98487f110b6a021cd97c94693fa4b39d892b148ad19ae64399396b34502ed6f598d7515418b69d0b22031776366a9f172f3b
diff --git a/app-containers/lxc/lxc-5.0.0-r1.ebuild b/app-containers/lxc/lxc-5.0.0-r1.ebuild
new file mode 100644
index 000000000000..1ab8d12bf9d6
--- /dev/null
+++ b/app-containers/lxc/lxc-5.0.0-r1.ebuild
@@ -0,0 +1,160 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 linux-info meson optfeature systemd verify-sig
+
+DESCRIPTION="A userspace interface for the Linux kernel containment features"
+HOMEPAGE="https://linuxcontainers.org/ https://github.com/lxc/lxc"
+SRC_URI="https://linuxcontainers.org/downloads/lxc/${P}.tar.gz
+ verify-sig? ( https://linuxcontainers.org/downloads/lxc/${P}.tar.gz.asc )"
+
+LICENSE="GPL-2 LGPL-2.1 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="apparmor +caps examples io-uring man pam seccomp selinux ssl systemd test +tools verify-sig"
+
+RDEPEND="acct-group/lxc
+ acct-user/lxc
+ apparmor? ( sys-libs/libapparmor )
+ caps? ( sys-libs/libcap[static-libs] )
+ io-uring? ( >=sys-libs/liburing-2:= )
+ pam? ( sys-libs/pam )
+ seccomp? ( sys-libs/libseccomp )
+ selinux? ( sys-libs/libselinux )
+ ssl? ( dev-libs/openssl:0= )
+ systemd? ( sys-apps/systemd )
+ tools? ( sys-libs/libcap[static-libs] )"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers"
+BDEPEND="virtual/pkgconfig
+ man? ( app-text/docbook2X )
+ verify-sig? ( sec-keys/openpgp-keys-linuxcontainers )"
+
+RESTRICT="!test? ( test )"
+
+CONFIG_CHECK="~!NETPRIO_CGROUP
+ ~CGROUPS
+ ~CGROUP_CPUACCT
+ ~CGROUP_DEVICE
+ ~CGROUP_FREEZER
+
+ ~CGROUP_SCHED
+ ~CPUSETS
+ ~IPC_NS
+ ~MACVLAN
+
+ ~MEMCG
+ ~NAMESPACES
+ ~NET_NS
+ ~PID_NS
+
+ ~POSIX_MQUEUE
+ ~USER_NS
+ ~UTS_NS
+ ~VETH"
+
+ERROR_CGROUP_FREEZER="CONFIG_CGROUP_FREEZER: needed to freeze containers"
+ERROR_MACVLAN="CONFIG_MACVLAN: needed for internal (inter-container) networking"
+ERROR_MEMCG="CONFIG_MEMCG: needed for memory resource control in containers"
+ERROR_NET_NS="CONFIG_NET_NS: needed for unshared network"
+ERROR_POSIX_MQUEUE="CONFIG_POSIX_MQUEUE: needed for lxc-execute command"
+ERROR_UTS_NS="CONFIG_UTS_NS: needed to unshare hostnames and uname info"
+ERROR_VETH="CONFIG_VETH: needed for internal (host-to-container) networking"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/linuxcontainers.asc
+
+DOCS=( AUTHORS CONTRIBUTING MAINTAINERS README.md doc/FAQ.txt )
+
+PATCHES=( "${FILESDIR}"/lxc-5.0.0-dont-depend-on-static-libcap.patch
+ "${FILESDIR}"/${PN}-5.0.0-fix-strerror-r-char-p-musl.patch )
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dcoverity-build=false
+ -Doss-fuzz=false
+
+ -Dcommands=true
+ -Dmemfd-rexec=true
+ -Dthread-safety=true
+
+ $(meson_use apparmor)
+ $(meson_use caps capabilities)
+ $(meson_use examples)
+ $(meson_use io-uring io-uring-event-loop)
+ $(meson_use man)
+ $(meson_use pam pam-cgroup)
+ $(meson_use seccomp)
+ $(meson_use selinux)
+ $(meson_use ssl openssl)
+ $(meson_use test tests)
+ $(meson_use tools)
+
+ -Ddata-path=/var/lib/lxc
+ -Ddoc-path=/usr/share/doc/${PF}
+ -Dlog-path=/var/log/lxc
+ -Drootfs-mount-path=/var/lib/lxc/rootfs
+ -Druntime-path=/run
+ )
+
+ if use systemd; then
+ local emesonargs+=( -Dinit-script="systemd" )
+ else
+ local emesonargs+=( -Dinit-script="sysvinit" )
+ fi
+
+ use tools && local emesonargs+=( -Dcapabilities=true )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # The main bash-completion file will collide with lxd, need to relocate and update symlinks.
+ mkdir -p "${ED}"/$(get_bashcompdir) || die "Failed to create bashcompdir."
+
+ if use tools; then
+ bashcomp_alias lxc-start lxc-{attach,cgroup,copy,console,create,destroy,device,execute,freeze,info,monitor,snapshot,stop,unfreeze,usernsexec,wait}
+ else
+ bashcomp_alias lxc-start lxc-usernsexec
+ fi
+
+ keepdir /var/lib/cache/lxc /var/lib/lib/lxc
+
+ find "${ED}" -name '*.la' -delete -o -name '*.a' -delete || die
+
+ # Replace upstream sysvinit/systemd files.
+ if use systemd; then
+ rm -r "${D}$(systemd_get_systemunitdir)" || die "Failed to remove systemd lib dir"
+ else
+ rm "${ED}"/etc/init.d/lxc-{containers,net} || die "Failed to remove sysvinit scripts"
+ fi
+
+ newinitd "${FILESDIR}/${PN}.initd.8" ${PN}
+ systemd_newunit "${FILESDIR}"/lxc-monitord.service.5.0.0 lxc-monitord.service
+ systemd_newunit "${FILESDIR}"/lxc-net.service.5.0.0 lxc-net.service
+ systemd_newunit "${FILESDIR}"/lxc.service-5.0.0 lxc.service
+ systemd_newunit "${FILESDIR}"/lxc_at.service.5.0.0 "lxc@.service"
+
+ if ! use apparmor; then
+ sed -i '/lxc-apparmor-load/d' "${D}$(systemd_get_systemunitdir)/lxc.service" || die "Failed to remove apparmor references from lxc.service systemd unit."
+ fi
+}
+
+pkg_postinst() {
+ elog "Please refer to "
+ elog "https://wiki.gentoo.org/wiki/LXC for introduction and usage guide."
+ elog
+ elog "Run 'lxc-checkconfig' to see optional kernel features."
+ elog
+
+ optfeature "automatic template scripts" app-containers/lxc-templates
+ optfeature "Debian-based distribution container image support" dev-util/debootstrap
+ optfeature "snapshot & restore functionality" sys-process/criu
+}