summaryrefslogtreecommitdiff
path: root/app-containers/docker-buildx/docker-buildx-0.10.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-21 01:09:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-21 01:09:27 +0100
commitd1849ceeb9c09150c11cc0d112883cfba503af27 (patch)
treeac029edd2ec6b691d3ef95fbc731a1b1325d9b82 /app-containers/docker-buildx/docker-buildx-0.10.2.ebuild
parent6b89cba67f554b60d139fd07623aef5cc724ec91 (diff)
gentoo auto-resync : 21:07:2023 - 01:09:27
Diffstat (limited to 'app-containers/docker-buildx/docker-buildx-0.10.2.ebuild')
-rw-r--r--app-containers/docker-buildx/docker-buildx-0.10.2.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/app-containers/docker-buildx/docker-buildx-0.10.2.ebuild b/app-containers/docker-buildx/docker-buildx-0.10.2.ebuild
deleted file mode 100644
index 4c9132f3eb3f..000000000000
--- a/app-containers/docker-buildx/docker-buildx-0.10.2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module
-
-MY_PN="buildx"
-DESCRIPTION="Docker CLI plugin for extended build capabilities with BuildKit"
-HOMEPAGE="https://github.com/docker/buildx"
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/docker/buildx.git"
-else
- SRC_URI="https://github.com/docker/buildx/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64"
- S="${WORKDIR}/${MY_PN}-${PV}"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-# This gives us the ability to neatly `-skip` tests.
-# not required once ::gentoo is all > 1.20
-RESTRICT="!test? ( test )"
-IUSE="test"
-
-BDEPEND="
- test? ( >=dev-lang/go-1.20 )
-"
-DEPEND="app-containers/docker"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- local _buildx_r='github.com/docker/buildx'
- ego build -mod=vendor -o docker-buildx \
- -ldflags "-linkmode=external \
- -X $_buildx_r/version.Version=${PV} \
- -X $_buildx_r/version.Revision=$(date -u +%FT%T%z) \
- -X $_buildx_r/version.Package=$_buildx_r" \
- ./cmd/buildx
-}
-
-src_test() {
- # TestGit can't work in a source tarball; TestReadTargets fails seemingly due to parallelism.
- if [[ ${PV} == 9999 ]]; then
- ego test ./... -skip "TestReadTargets"
- else
- ego test ./... -skip "TestGit|TestReadTargets"
- fi
-}
-
-src_install() {
- exeinto /usr/libexec/docker/cli-plugins
- doexe docker-buildx
-
- dodoc README.md
-}