summaryrefslogtreecommitdiff
path: root/app-containers/devcontainer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-07 18:01:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-07 18:01:02 +0100
commitf87d83ebb0d6ae5915c4775f762a0b5bceb9b2a5 (patch)
tree69b6db4e0c713061615ae368d69a16b0302e5bb9 /app-containers/devcontainer
parenta519cf56a0e5e456006d39c06f68de5e11c2f7e9 (diff)
gentoo auto-resync : 07:10:2023 - 18:01:02
Diffstat (limited to 'app-containers/devcontainer')
-rw-r--r--app-containers/devcontainer/Manifest3
-rw-r--r--app-containers/devcontainer/devcontainer-0.52.0.ebuild46
-rw-r--r--app-containers/devcontainer/metadata.xml21
3 files changed, 70 insertions, 0 deletions
diff --git a/app-containers/devcontainer/Manifest b/app-containers/devcontainer/Manifest
new file mode 100644
index 000000000000..3b937bec7a96
--- /dev/null
+++ b/app-containers/devcontainer/Manifest
@@ -0,0 +1,3 @@
+DIST devcontainer-0.52.0.tgz 614149 BLAKE2B 1e71d4772ec799cf8709d1d350cb8db0ea61dd2c7e96be4d35555675f9784bb1ff71ba95b6816fa9f8b6bd62c9a2b801871d51ab9fd8b564052c5939be603e2f SHA512 1790c6f2933c343b17a52d87a065e78c6e90b59249efb14c4601fc39de9a89aa6a93d100664ad3180a779c01fc181a31e59026af6bd646c214a616c61aed634c
+EBUILD devcontainer-0.52.0.ebuild 872 BLAKE2B b63cff73a09e5914d7dc96c215577fc7805efdc3902f42f0fb33e15ab82bdc40cf3bd96f4cdcd200bea145eb1bb8f72ccd812c44914ebd93bca23a609b493e8b SHA512 7d2a15bce975c2617801010c25be45255b94c36e60b12926e32100c1ef7169fd131a44c594f03cf3ff27456446eb54000fe5e39f1e8b99dde4ebc7ffac5e112f
+MISC metadata.xml 886 BLAKE2B 6255ba2337a21bd814e0472648cf4eb78b7c3e6ca6ead9f154cc70b662b7721ddc62137f1ebf542123c7d716e0ff94527f7a1aa99786446c7ffd36bbbf9c9efe SHA512 6dd2c48ee1dc5b722768780f20c32dd424af327fe7a580eb4f8ce31712dff211ecc9ebe1eae4ca22ec3a90ef5b3a6690407b24fc11c45000a7d986871956d407
diff --git a/app-containers/devcontainer/devcontainer-0.52.0.ebuild b/app-containers/devcontainer/devcontainer-0.52.0.ebuild
new file mode 100644
index 000000000000..399665b46cde
--- /dev/null
+++ b/app-containers/devcontainer/devcontainer-0.52.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference implementation of the Development Containers specification"
+HOMEPAGE="https://containers.dev/
+ https://github.com/devcontainers/cli/"
+SRC_URI="https://registry.npmjs.org/@devcontainers/cli/-/cli-${PV}.tgz
+ -> ${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ net-libs/nodejs
+"
+BDEPEND="
+ >=net-libs/nodejs-16[npm]
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local -a my_npm_opts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}/usr"
+ --progress false
+ --verbose
+ )
+ npm "${my_npm_opts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"
+
+ einstalldocs
+}
diff --git a/app-containers/devcontainer/metadata.xml b/app-containers/devcontainer/metadata.xml
new file mode 100644
index 000000000000..07653ea3406a
--- /dev/null
+++ b/app-containers/devcontainer/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ A Development Container (or Dev Container for short) allows you to use a
+ container as a full-featured development environment. It can be used to run
+ an application, to separate tools, libraries, or runtimes needed for
+ working with a codebase, and to aid in continuous integration and testing.
+ Dev containers can be run locally or remotely, in a private or public
+ cloud, in a variety of supporting tools and editors.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/devcontainers/cli/issues/</bugs-to>
+ <remote-id type="github">devcontainers/cli</remote-id>
+ </upstream>
+</pkgmetadata>