summaryrefslogtreecommitdiff
path: root/app-containers/crun/crun-1.4.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-04 02:04:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-04 02:04:17 +0100
commit00d9a8fc3e9e5bafeff6747e978c1685b384e587 (patch)
tree43c6db3767706ffe339a7040cb0a5dea8bd1ef26 /app-containers/crun/crun-1.4.5.ebuild
parent799073eb168d35819904276f6c912be4ac76166a (diff)
gentoo auto-resync : 04:08:2022 - 02:04:17
Diffstat (limited to 'app-containers/crun/crun-1.4.5.ebuild')
-rw-r--r--app-containers/crun/crun-1.4.5.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/app-containers/crun/crun-1.4.5.ebuild b/app-containers/crun/crun-1.4.5.ebuild
index 7beee3b50821..1cc9dd0d9d26 100644
--- a/app-containers/crun/crun-1.4.5.ebuild
+++ b/app-containers/crun/crun-1.4.5.ebuild
@@ -5,7 +5,8 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit python-any-r1
+# Can drop autotools/eautoreconf after next release & glibc patch gone
+inherit autotools python-any-r1
DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
HOMEPAGE="https://github.com/containers/crun"
@@ -36,6 +37,16 @@ BDEPEND="
# required to create linux "containers".
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.5-glibc-2.36.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
src_configure() {
local myeconfargs=(
$(use_enable bpf)