summaryrefslogtreecommitdiff
path: root/app-containers/cosign/cosign-1.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-26 20:59:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-26 20:59:46 +0100
commit1d4cc2fdaa7a04ed1fe39b6cf1d892bd83bd8030 (patch)
tree15bcf4c47e609ca1bd3dc164c91a9cfbe566dd3f /app-containers/cosign/cosign-1.10.0.ebuild
parent1503b28e7a30c164cab750c27268f704b8a5cec6 (diff)
gentoo auto-resync : 26:07:2022 - 20:59:46
Diffstat (limited to 'app-containers/cosign/cosign-1.10.0.ebuild')
-rw-r--r--app-containers/cosign/cosign-1.10.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-containers/cosign/cosign-1.10.0.ebuild b/app-containers/cosign/cosign-1.10.0.ebuild
new file mode 100644
index 000000000000..194effdf1cd3
--- /dev/null
+++ b/app-containers/cosign/cosign-1.10.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GIT_HASH=3a6088d03d7c053f9b3bd61ed07fba92133579cf
+inherit go-module
+
+DESCRIPTION="container signing utility"
+HOMEPAGE="https://sigstore.dev"
+SRC_URI="https://github.com/sigstore/cosign/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="test"
+
+src_compile() {
+ emake \
+ GIT_HASH=${GIT_HASH} \
+ GIT_VERSION=v${PV} \
+ GIT_TREESTATE=clean
+}
+
+src_install() {
+ dobin cosign
+ einstalldocs
+}