summaryrefslogtreecommitdiff
path: root/app-containers/catatonit/catatonit-0.1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-containers/catatonit/catatonit-0.1.7.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-containers/catatonit/catatonit-0.1.7.ebuild')
-rw-r--r--app-containers/catatonit/catatonit-0.1.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-containers/catatonit/catatonit-0.1.7.ebuild b/app-containers/catatonit/catatonit-0.1.7.ebuild
new file mode 100644
index 000000000000..bc3f9fc2be56
--- /dev/null
+++ b/app-containers/catatonit/catatonit-0.1.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A container init that is so simple it's effectively brain-dead"
+HOMEPAGE="https://github.com/openSUSE/catatonit"
+SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/openSUSE/catatonit/pull/19.patch -> ${P}-automake.patch"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+
+PATCHES=("${DISTDIR}/${P}-automake.patch")
+
+src_configure() {
+ ./autogen.sh || die
+ default
+}
+
+src_install() {
+ default
+ dodir /usr/libexec/podman
+ ln "${ED}/usr/"{bin,libexec/podman}/catatonit || die
+}