summaryrefslogtreecommitdiff
path: root/app-containers/buildah
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-04 07:16:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-04 07:16:51 +0100
commitbf99f8024d68382f76665735c70ae912331bc2ca (patch)
tree6fa5830f88fa9ddb794b019c25b83a76ec410df4 /app-containers/buildah
parentc1bd8495f43d1e8a084ac779db6e4623aaa8d6ad (diff)
gentoo auto-resync : 04:10:2022 - 07:16:51
Diffstat (limited to 'app-containers/buildah')
-rw-r--r--app-containers/buildah/Manifest2
-rw-r--r--app-containers/buildah/buildah-1.28.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/app-containers/buildah/Manifest b/app-containers/buildah/Manifest
index 0d1756031767..4ff94da16782 100644
--- a/app-containers/buildah/Manifest
+++ b/app-containers/buildah/Manifest
@@ -1,3 +1,5 @@
DIST buildah-1.27.1.tar.gz 14825932 BLAKE2B bf290eeb4d96d255c7cdaa07af49eff44191664ac7dee255c7979656383daaa93c3673ba82ac1cbff033de769ffa08ad027f5d91c81b08a36222cb73e8a1e399 SHA512 a5e2ddf837e613554ffe8fe9c15ac9c8f9c2564c403e5544df7fb8802962581fb4e9dd4361c28c93443ede74c20c82f1631990e443c7895a3b4c3b8a659ee05a
+DIST buildah-1.28.0.tar.gz 14579386 BLAKE2B effc7d0a154e30790585c19e19655f98026c34687e79b91777700bc2f387b96896d88855cd5ec34573dd2678e4a30a832c39f789d53b61b45cb5f682dacd252e SHA512 f5e82a22648fa0d0ba7f5dcf3b97a2ec1182f31d3e03cd2624e01fe76fcdddf0a5605c59816eeef6401d151864b6b6be493c144b83f5667ab3947eea902f0086
EBUILD buildah-1.27.1.ebuild 1196 BLAKE2B b9b0c03282cd8d03a88649c1156361c8eaf64009147a8f78b9f9f7ab7c72dbb3d340221bc73e36ea1478d46a72e6c57622451c34b8e7f511fba93554dd0afdb7 SHA512 2c64885a361dbe355b5d8cfce1e9febc223fd1331dc3e7358f9f32f2281e8992d00c74de2337aafde4aab6473bfdd2a67aaab7597de8904bca2ad913c060b6a7
+EBUILD buildah-1.28.0.ebuild 1198 BLAKE2B 3c5a4ddabe6075badd8595d46c9f12764e173690fb5cfc67cb5a2e60cf8bc3dbce1d6d05d548a41740cf346e9498313c05497d4a71632848d60b6eb3d9d740ac SHA512 128aae74d0c13b6ec7a9cf7a2c3b09cefd13606ab4c685d72d85bca6f36723943a08918d315dc3f8328c622bdde2fd099fa3bce35db99e297c44e802c97d9df9
MISC metadata.xml 328 BLAKE2B 55d2d2b5cc972b7e6b6fb77d14e79e304adcbc7056ff351f5ee3cac6cf5f83b4ef2a10c70754d1d30a5ecd88e652abc07cddd8005c3767e7f709c0c5cb61d068 SHA512 7520f5745909da195d4bfdd750e4c716c461a3789adfde56dd9be46b91dfb789653d642c0958b5a2950eea220cc00143bfcd5db402fcc2578c8fe5f8ff69275f
diff --git a/app-containers/buildah/buildah-1.28.0.ebuild b/app-containers/buildah/buildah-1.28.0.ebuild
new file mode 100644
index 000000000000..2b234b883551
--- /dev/null
+++ b/app-containers/buildah/buildah-1.28.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 go-module
+GIT_COMMIT=79f41e32
+
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="selinux"
+
+RDEPEND="app-crypt/gpgme:=
+ app-containers/skopeo
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-apps/shadow:=
+ sys-fs/lvm2:=
+ sys-libs/libseccomp:=
+ selinux? ( sys-libs/libselinux:= )"
+DEPEND="${RDEPEND}"
+
+RESTRICT+=" test"
+
+src_prepare() {
+ default
+ [[ -f selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ selinux_tag.sh || die; }
+ sed -i -e 's/make -C/$(MAKE) -C/' Makefile || die 'sed failed'
+}
+
+src_compile() {
+ emake GIT_COMMIT=${GIT_COMMIT} all
+}
+
+src_install() {
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
+ doman docs/*.1
+ dodoc -r docs/tutorials
+ dobin bin/{${PN},imgtype}
+ dobashcomp contrib/completions/bash/buildah
+}
+
+src_test() {
+ emake test-unit
+}