summaryrefslogtreecommitdiff
path: root/app-containers/apptainer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-30 16:00:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-30 16:00:34 +0100
commit8b63b46fda85d54cfbe94df2444a3ddd3e63b8e4 (patch)
treeced0310e563ec21deb23ca12d5459aebadba36f6 /app-containers/apptainer
parent93c735f5f1ff867aadcc947348d984ff2c5a29cb (diff)
gentoo auto-resync : 30:03:2023 - 16:00:34
Diffstat (limited to 'app-containers/apptainer')
-rw-r--r--app-containers/apptainer/Manifest2
-rw-r--r--app-containers/apptainer/apptainer-1.1.7.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/app-containers/apptainer/Manifest b/app-containers/apptainer/Manifest
index a5e17353cdf3..866b460c2e80 100644
--- a/app-containers/apptainer/Manifest
+++ b/app-containers/apptainer/Manifest
@@ -1,6 +1,8 @@
AUX apptainer-1.0.2-trim_upstream_cflags.patch 1142 BLAKE2B 7238229b70a8ac37f3401a163d19dc705adb6a4ab6355e4eaa386ad5c639bfc1443cf61507112a53b66816399ca5fe2c32de964dd602ea16c5dfbf9003343f8c SHA512 1351ee000274567bb5a63aa740fbc43510d84ccad42c9af0c555943b99d93d86a2b036801c1681b93548a874bda1bab3304c2bf0da83bbca102a71e82574a032
DIST apptainer-1.1.2.tar.gz 12896912 BLAKE2B 29a8df78617661e0a181955942e8321c112a69efaf15f4bb3e1563cc0789197916a3be1eb5396fb608d57b0edd5d5de2a70a2bda935095d8d511410660ebc106 SHA512 3fad253379a87ea790f22a14aec703296f606255d4ce847454a59f9dba0b9a6fc449489e7760c4696c1df90fc6abec198934310c1b762e33a83c72cafc7cb370
DIST apptainer-1.1.6.tar.gz 12914465 BLAKE2B a04ed9b9b429d7885d6c91f72d574d2a3a2955fdbe5cb2d30b59744b1f3bfb6f7d4f07ce7f1863caa83fb3361d7fdd2739b82334458d606ce053de43e1e9f755 SHA512 dd38abe1e343352e29a8a1fd1922901e4d48282fef641c75360253392ad53c6f1e5f7510ef612594e29db5f090fb41ff55b9d52d126be253450b0630fc7d383b
+DIST apptainer-1.1.7.tar.gz 12926719 BLAKE2B ed12ae933166f03742c04551f3b231458e9ccd2d62184e965f91ab6f996bd32aa53b4efd6552e8f83a3735ff38bd48cb9c4450b9b6da064fe9029ea15555282e SHA512 10a4faa28f08961d483a63384671388d14ceedb150af752da576c035be79372401fd6ddb2eb5491569bb79b250c0f1e89e1b747463defc4a7f495610ebf2d371
EBUILD apptainer-1.1.2.ebuild 2452 BLAKE2B ad348c5bc7cc3097e69a43313c6118c57dc76b499cfa38a82ed9e07bd9668f9bdcdd1ff92d37f8d566fd85e8df8a2cf94d7abb629bbb7583ddc375ec47a1b583 SHA512 3bc7302d9d4448fa493f77646aa1fcd85a0c19b8b50c54bdaf47310b41ec28c01dc8137229e1c39e56838912fcc9b996c515bbf04caba23dcdcc16839f95b2f5
EBUILD apptainer-1.1.6.ebuild 2463 BLAKE2B 331d94b48d64fc381d906a945ec557e898b2151ae98156090c13340f018aaa3fca2c1a8bb72a075ff642a9e5ae68229c55cc7d443c57274603127467df4c5df3 SHA512 bd6dd3d00c06634501d3af8b0358c3f4225414603f5280027a0d7376306f6340c7ff01519dddf1248828dc680bd5e0ee91232ff25a1f293de3c0b19d0e03f214
+EBUILD apptainer-1.1.7.ebuild 2463 BLAKE2B 331d94b48d64fc381d906a945ec557e898b2151ae98156090c13340f018aaa3fca2c1a8bb72a075ff642a9e5ae68229c55cc7d443c57274603127467df4c5df3 SHA512 bd6dd3d00c06634501d3af8b0358c3f4225414603f5280027a0d7376306f6340c7ff01519dddf1248828dc680bd5e0ee91232ff25a1f293de3c0b19d0e03f214
MISC metadata.xml 454 BLAKE2B 7891b6acae30424b8b6877166b856c1113a13e40ebec9051935df10a0650bf941f52d75bdb6a4258795e07b080082979469b8b8242d2ddd56c52f9c5b6759f0e SHA512 ef53c2dee45734f36403ab71549494f3c24707bc183353e4bd9c548a97b3ab5d7877f4fc9d311d9e86ab249cbdb379f0a1a211ee36afda99fd552f0a5cac30bb
diff --git a/app-containers/apptainer/apptainer-1.1.7.ebuild b/app-containers/apptainer/apptainer-1.1.7.ebuild
new file mode 100644
index 000000000000..11042b31127b
--- /dev/null
+++ b/app-containers/apptainer/apptainer-1.1.7.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="The container system for secure high-performance computing"
+HOMEPAGE="https://apptainer.org/"
+SRC_URI="https://github.com/apptainer/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples +network suid systemd"
+
+# Do not complain about CFLAGS etc. since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+DEPEND="app-crypt/gpgme
+ >=dev-lang/go-1.17.6
+ dev-libs/openssl
+ sys-apps/util-linux
+ sys-fs/cryptsetup
+ sys-fs/squashfs-tools
+ sys-libs/libseccomp
+ !suid? (
+ sys-fs/e2fsprogs[fuse]
+ sys-fs/squashfuse
+ )"
+RDEPEND="${DEPEND}
+ !sys-cluster/singularity"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~SQUASHFS"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.2-trim_upstream_cflags.patch
+)
+
+DOCS=( README.md CONTRIBUTORS.md CONTRIBUTING.md )
+
+src_configure() {
+ local myconfargs=(
+ -c "$(tc-getBUILD_CC)" \
+ -x "$(tc-getBUILD_CXX)" \
+ -C "$(tc-getCC)" \
+ -X "$(tc-getCXX)" \
+ --prefix="${EPREFIX}"/usr \
+ --sysconfdir="${EPREFIX}"/etc \
+ --runstatedir="${EPREFIX}"/run \
+ --localstatedir="${EPREFIX}"/var \
+ $(usex network "" "--without-network") \
+ $(use_with suid)
+ )
+ ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
+}
+
+src_compile() {
+ emake -C builddir
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C builddir install
+ keepdir /var/${PN}/mnt/session
+
+ if use systemd; then
+ sed -i -e '/systemd cgroups/ s/no/yes/' "${ED}"/etc/${PN}/${PN}.conf \
+ || die "Failed to enable systemd use in configuration"
+ else
+ sed -i -e '/systemd cgroups/ s/yes/no/' "${ED}"/etc/${PN}/${PN}.conf \
+ || die "Failed to disable systemd use in configuration"
+ fi
+
+ einstalldocs
+ if use examples; then
+ dodoc -r examples
+ fi
+}
+
+pkg_postinst() {
+ if ! use suid; then
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.1.0; then
+ ewarn "Since version 1.1.0 ${PN} no longer installs setuid-root components by default, relying on unprivileged user namespaces instead. For details, see https://apptainer.org/docs/admin/main/user_namespace.html"
+ ewarn "Make sure user namespaces (possibly except network ones for improved security) are enabled on your system, or re-enable installation of setuid root components by passing USE=suid to ${CATEGORY}/${PN}"
+ break
+ fi
+ done
+ fi
+}