summaryrefslogtreecommitdiff
path: root/app-containers/apptainer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-18 23:07:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-18 23:07:14 +0100
commit4eeee822487f780361d7d47b4c1b999f93e15b27 (patch)
treee0f304adb25f3e070c50d4284d4d067a9a7d1ec8 /app-containers/apptainer
parent4be6deadf3e814bc37585cde9dc08faad2561453 (diff)
gentoo auto-resync : 18:09:2023 - 23:07:14
Diffstat (limited to 'app-containers/apptainer')
-rw-r--r--app-containers/apptainer/Manifest2
-rw-r--r--app-containers/apptainer/apptainer-1.2.3.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/app-containers/apptainer/Manifest b/app-containers/apptainer/Manifest
index d64a4c19ee3c..a89cb042ac91 100644
--- a/app-containers/apptainer/Manifest
+++ b/app-containers/apptainer/Manifest
@@ -1,6 +1,8 @@
AUX apptainer-1.0.2-trim_upstream_cflags.patch 1142 BLAKE2B 7238229b70a8ac37f3401a163d19dc705adb6a4ab6355e4eaa386ad5c639bfc1443cf61507112a53b66816399ca5fe2c32de964dd602ea16c5dfbf9003343f8c SHA512 1351ee000274567bb5a63aa740fbc43510d84ccad42c9af0c555943b99d93d86a2b036801c1681b93548a874bda1bab3304c2bf0da83bbca102a71e82574a032
DIST apptainer-1.1.8.tar.gz 12935652 BLAKE2B a9c34bb407d002fa50cb5f96c0e7071aa05f8a17f3c98689d9392f23fc9336364137f23b582eb84ba860497f274fc393634d3702df62b99ad4320d0ac1ed69b0 SHA512 726fd7da3d43980c3d3914b089288d27cde941fa0ff7e206b3330bc7b0085de45a192e12ed794c2d81661d90260e10512bca61bfd7344cb1ae74ff64b5f8ebb5
DIST apptainer-1.2.2.tar.gz 14398077 BLAKE2B 86f5ed5218928854a7266251378480fdf76b370dad194995d55b5b85127b82dee2f2462b2b5a7ce1bd6e86552890286cf6c6f28c14c6ae98f7e56f4a3078c78f SHA512 e93f4b01379fdfce475bac3896b51fec4bbb208bd643b839572e2b9844a653e60f292b560207b460f1d087a49464291430dd6705b11741885900746856f33384
+DIST apptainer-1.2.3.tar.gz 14387465 BLAKE2B b7aacb0e85ea1f8cbd2b27f321f539cee8d048cdb7f75894e9d4be39add40a0c61763bc4e8984542b1410ddea4ca67c9d341505856870075ec3f1907d5c9bc98 SHA512 d9146760c6602cddc9d7a29bfb637fe5332adb405e54667812a618245052334a97c23198b7d59296522f614654e555e083e4ed0eec72115469b3be35e2f5a0ae
EBUILD apptainer-1.1.8.ebuild 2462 BLAKE2B 082c414493a55596ddaf8c4233e3fc43faaf95a8e467eadf59bb1b027072c2d17444ded33a22086fef39a2898a16a90cd20af47c5df08aef1885dfcd71110ad1 SHA512 106f6814f987d154bd7dd7dab2271c5a1e30be9e6f3a04d49930bb31ae327bbeffae6c193d4ee9bf608d039e009cfb50d94a6f4b9b2f582b6bb30026deefa32e
EBUILD apptainer-1.2.2.ebuild 2463 BLAKE2B 7df515094920e98c8ddecaee7640504401cba76d76cb8ba7d7081fca4070d11d9e6bd01f5f23d83816da5b3f2d7cd4846fe1a02623acd69915b45580f9c9a111 SHA512 1184828ae023c1b50e7e61edebd44ca79bbf907d6fa0ee2ee5e09e60ab7ce0f16e897181bc032bcebcf496863a46cd3556bff29c91a243a928ee4cf31c6ec2ca
+EBUILD apptainer-1.2.3.ebuild 2463 BLAKE2B 7df515094920e98c8ddecaee7640504401cba76d76cb8ba7d7081fca4070d11d9e6bd01f5f23d83816da5b3f2d7cd4846fe1a02623acd69915b45580f9c9a111 SHA512 1184828ae023c1b50e7e61edebd44ca79bbf907d6fa0ee2ee5e09e60ab7ce0f16e897181bc032bcebcf496863a46cd3556bff29c91a243a928ee4cf31c6ec2ca
MISC metadata.xml 454 BLAKE2B 7891b6acae30424b8b6877166b856c1113a13e40ebec9051935df10a0650bf941f52d75bdb6a4258795e07b080082979469b8b8242d2ddd56c52f9c5b6759f0e SHA512 ef53c2dee45734f36403ab71549494f3c24707bc183353e4bd9c548a97b3ab5d7877f4fc9d311d9e86ab249cbdb379f0a1a211ee36afda99fd552f0a5cac30bb
diff --git a/app-containers/apptainer/apptainer-1.2.3.ebuild b/app-containers/apptainer/apptainer-1.2.3.ebuild
new file mode 100644
index 000000000000..b5e7811c6f00
--- /dev/null
+++ b/app-containers/apptainer/apptainer-1.2.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="The container system for secure high-performance computing"
+HOMEPAGE="https://apptainer.org/"
+SRC_URI="https://github.com/apptainer/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples +network suid systemd"
+
+# Do not complain about CFLAGS etc. since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+DEPEND="app-crypt/gpgme
+ >=dev-lang/go-1.19.0
+ dev-libs/openssl
+ sys-apps/util-linux
+ sys-fs/cryptsetup
+ sys-fs/squashfs-tools
+ sys-libs/libseccomp
+ !suid? (
+ sys-fs/e2fsprogs[fuse]
+ sys-fs/squashfuse
+ )"
+RDEPEND="${DEPEND}
+ !sys-cluster/singularity"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~SQUASHFS"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.2-trim_upstream_cflags.patch
+)
+
+DOCS=( README.md CONTRIBUTORS.md CONTRIBUTING.md )
+
+src_configure() {
+ local myconfargs=(
+ -c "$(tc-getBUILD_CC)" \
+ -x "$(tc-getBUILD_CXX)" \
+ -C "$(tc-getCC)" \
+ -X "$(tc-getCXX)" \
+ --prefix="${EPREFIX}"/usr \
+ --sysconfdir="${EPREFIX}"/etc \
+ --runstatedir="${EPREFIX}"/run \
+ --localstatedir="${EPREFIX}"/var \
+ $(usex network "" "--without-network") \
+ $(use_with suid)
+ )
+ ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
+}
+
+src_compile() {
+ emake -C builddir
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C builddir install
+ keepdir /var/${PN}/mnt/session
+
+ if use systemd; then
+ sed -i -e '/systemd cgroups/ s/no/yes/' "${ED}"/etc/${PN}/${PN}.conf \
+ || die "Failed to enable systemd use in configuration"
+ else
+ sed -i -e '/systemd cgroups/ s/yes/no/' "${ED}"/etc/${PN}/${PN}.conf \
+ || die "Failed to disable systemd use in configuration"
+ fi
+
+ einstalldocs
+ if use examples; then
+ dodoc -r examples
+ fi
+}
+
+pkg_postinst() {
+ if ! use suid; then
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.1.0; then
+ ewarn "Since version 1.1.0 ${PN} no longer installs setuid-root components by default, relying on unprivileged user namespaces instead. For details, see https://apptainer.org/docs/admin/main/user_namespace.html"
+ ewarn "Make sure user namespaces (possibly except network ones for improved security) are enabled on your system, or re-enable installation of setuid root components by passing USE=suid to ${CATEGORY}/${PN}"
+ break
+ fi
+ done
+ fi
+}