summaryrefslogtreecommitdiff
path: root/app-cdr/xbiso/xbiso-0.6.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-cdr/xbiso/xbiso-0.6.1-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-cdr/xbiso/xbiso-0.6.1-r2.ebuild')
-rw-r--r--app-cdr/xbiso/xbiso-0.6.1-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-cdr/xbiso/xbiso-0.6.1-r2.ebuild b/app-cdr/xbiso/xbiso-0.6.1-r2.ebuild
new file mode 100644
index 000000000000..88cc5dc936e9
--- /dev/null
+++ b/app-cdr/xbiso/xbiso-0.6.1-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Xbox xdvdfs ISO extraction utility"
+HOMEPAGE="https://sourceforge.net/projects/xbiso/"
+SRC_URI="mirror://sourceforge/xbiso/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ftp"
+
+RDEPEND="ftp? ( <net-libs/ftplib-4 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e 's:C) $(CFLAGS):C) $(LDFLAGS) $(CFLAGS):' Makefile.in || die #337769
+ epatch "${FILESDIR}/${P}-libs.patch"
+ mv configure.in configure.ac || die #426262
+ eautoreconf
+}
+
+src_configure() {
+ # for this package, interix behaves the same as BSD
+ [[ ${CHOST} == *-interix* ]] && append-flags -D_BSD
+
+ econf \
+ $(use_enable ftp)
+}
+
+src_install() {
+ dobin xbiso
+ dodoc CHANGELOG README
+}