summaryrefslogtreecommitdiff
path: root/app-cdr/disc-cover/disc-cover-1.5.6-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-27 03:00:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-27 03:00:39 +0100
commitfe618c8b8c934661d2297b2aeb0615a48e787691 (patch)
tree24a8209687e0ff34205acd703b6b80e7c6897f81 /app-cdr/disc-cover/disc-cover-1.5.6-r2.ebuild
parent1d4cc2fdaa7a04ed1fe39b6cf1d892bd83bd8030 (diff)
gentoo auto-resync : 27:07:2022 - 03:00:38
Diffstat (limited to 'app-cdr/disc-cover/disc-cover-1.5.6-r2.ebuild')
-rw-r--r--app-cdr/disc-cover/disc-cover-1.5.6-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-cdr/disc-cover/disc-cover-1.5.6-r2.ebuild b/app-cdr/disc-cover/disc-cover-1.5.6-r2.ebuild
new file mode 100644
index 000000000000..a1ac3c577040
--- /dev/null
+++ b/app-cdr/disc-cover/disc-cover-1.5.6-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Creates CD-Covers via LaTeX by fetching cd-info from freedb.org or local file"
+HOMEPAGE="https://web.archive.org/web/20151104062521/http://www.vanhemert.co.uk/disc-cover.html"
+SRC_URI="http://www.vanhemert.co.uk/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+
+BDEPEND="dev-lang/perl"
+RDEPEND="${BDEPEND}
+ dev-perl/Audio-CD-disc-cover
+ virtual/latex-base"
+
+src_compile() {
+ pod2man disc-cover > disc-cover.1 || die
+}
+
+src_install() {
+ dobin disc-cover
+
+ einstalldocs
+ doman disc-cover.1
+
+ insinto /usr/share/disc-cover/templates
+ doins -r templates/.
+}