summaryrefslogtreecommitdiff
path: root/app-cdr/cdw/cdw-0.8.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /app-cdr/cdw/cdw-0.8.1-r2.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'app-cdr/cdw/cdw-0.8.1-r2.ebuild')
-rw-r--r--app-cdr/cdw/cdw-0.8.1-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-cdr/cdw/cdw-0.8.1-r2.ebuild b/app-cdr/cdw/cdw-0.8.1-r2.ebuild
new file mode 100644
index 000000000000..045f963648c3
--- /dev/null
+++ b/app-cdr/cdw/cdw-0.8.1-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="An ncurses based console frontend for cdrtools and dvd+rw-tools"
+HOMEPAGE="http://cdw.sourceforge.net"
+SRC_URI="mirror://sourceforge/cdw/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+RDEPEND="
+ app-cdr/cdrtools
+ app-cdr/dvd+rw-tools
+ dev-libs/libburn
+ dev-libs/libcdio:=[-minimal]
+ sys-libs/ncurses:=[unicode(+)]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-0.8.1-fix-ar-call.patch" )
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS cdw.conf )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )"
+}