summaryrefslogtreecommitdiff
path: root/app-benchmarks/volanomark
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-benchmarks/volanomark
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-benchmarks/volanomark')
-rw-r--r--app-benchmarks/volanomark/Manifest3
-rw-r--r--app-benchmarks/volanomark/metadata.xml6
-rw-r--r--app-benchmarks/volanomark/volanomark-2.5.0.9.ebuild66
3 files changed, 75 insertions, 0 deletions
diff --git a/app-benchmarks/volanomark/Manifest b/app-benchmarks/volanomark/Manifest
new file mode 100644
index 000000000000..098905b40050
--- /dev/null
+++ b/app-benchmarks/volanomark/Manifest
@@ -0,0 +1,3 @@
+DIST vmark2_5_0_9.class 1591590 BLAKE2B c67b18969f5ceb42f6d68d37260e43d3d30508956ddb2091a59852d5d151606ca3f30205cde397f3212ba5dfd4e4d109802ddcf0cdc6c851b20d07ab6cf5f5be SHA512 002953f780bfb2fa0f9663f6ee2228abbf277e98ebdc69dce3c0e9f03147e0bdb80ae381daf29838790c13aefc83406b61428871a890dcae2396a5c59fcee8bf
+EBUILD volanomark-2.5.0.9.ebuild 1771 BLAKE2B 22fcdcae01354588a8284f4a0afda3a909b5c12246136fdd3516922459b576f746317164caf8815b39bd22d96105d27c5fca0c713fc6126fab627d802c4bb601 SHA512 2e83a2adbb8da635e60eb97bb7fa1443deaa6fe29ac85db7ba63dc4bded121c9b610abeee1b309ea1d74e43581b34b3e464328f3b3ce458a49b4fff22cf58491
+MISC metadata.xml 221 BLAKE2B fddb0708e4743cdfe978ab6d0b49a8fc3213b1d7830a4c85ff6a2f4dac146729798ee797e9c35ac311982199a48cdf9a51c47a3bc566c23715ebe9735f98d9e8 SHA512 239603806c8f5664d980a58bed0512b05b581342df90ed690086c86db2290edbb38183fe2cc1805b4245f9e87763c86c6f945022ac9704f8f9214dd73c5d2e07
diff --git a/app-benchmarks/volanomark/metadata.xml b/app-benchmarks/volanomark/metadata.xml
new file mode 100644
index 000000000000..c2a23a7dec6b
--- /dev/null
+++ b/app-benchmarks/volanomark/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+<longdescription>Java Benchmark test</longdescription>
+</pkgmetadata>
diff --git a/app-benchmarks/volanomark/volanomark-2.5.0.9.ebuild b/app-benchmarks/volanomark/volanomark-2.5.0.9.ebuild
new file mode 100644
index 000000000000..caf8ee111386
--- /dev/null
+++ b/app-benchmarks/volanomark/volanomark-2.5.0.9.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+DESCRIPTION="Java server benchmark utility"
+HOMEPAGE="http://www.volano.com/benchmarks.html"
+SRC_URI="http://www.volano.com/pub/vmark2_5_0_9.class"
+LICENSE="Volano"
+
+# Below because of licensing.
+RESTRICT="mirror"
+
+SLOT="0"
+
+KEYWORDS="x86 amd64"
+IUSE=""
+DEPEND="virtual/jre
+ >=sys-apps/sed-4
+ sys-apps/net-tools"
+
+RDEPEND="virtual/jre"
+
+src_unpack() {
+ einfo "No unpack required"
+}
+
+src_install() {
+ dodir /opt/${PN}
+ java -classpath "${DISTDIR}" vmark2_5_0_9 -o "${D}"/opt/${PN}
+ chmod 755 "${D}"/opt/${PN}/*.sh
+ sed -i -e "s#^host=.*#cd /opt/${PN}\nhost=`hostname`#" \
+ -e 's:"$java":java:g' \
+ -e 's:! -f: -z :' \
+ -e 's:-Sn:-n:' \
+ "${D}"/opt/${PN}/startup.sh
+
+ sed -i -e "s#^./startup.sh#/opt/${PN}/startup.sh#g" "${D}"/opt/${PN}/*.sh
+
+ # Set stack-size correctly for different arches
+ if [ "${ARCH}" == "amd64" ] ; then
+ sed -i -e 's:Xss96:Xss512:' "${D}"/opt/${PN}/startup.sh
+ else
+ sed -i -e 's:Xss96:Xss128:' "${D}"/opt/${PN}/startup.sh
+ fi
+
+ keepdir /opt/${PN}/logs
+}
+
+pkg_postinst() {
+
+ ewarn "The vendor provided installation script is somewhat broken!"
+ elog
+ elog "startup.sh was patched to allow the use of the current JVM as"
+ elog "selected by java-config. This means that regardless of the"
+ elog "Java vendor you specify to ${PN}, it will STILL use the default"
+ elog "JVM configured via java-config"
+ elog
+ elog "Just make sure that when you run ${PN}, the Java vendor you specify"
+ elog "matches up with what java-config is configured for. Otherwise specific"
+ elog "vendor specific options runtime may not work."
+ elog
+ elog "Remember to check the host property in startup.sh to the host that is"
+ elog "running the server"
+
+}