summaryrefslogtreecommitdiff
path: root/app-benchmarks/stress-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-benchmarks/stress-ng
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-benchmarks/stress-ng')
-rw-r--r--app-benchmarks/stress-ng/Manifest4
-rw-r--r--app-benchmarks/stress-ng/files/stress-ng-0.09.31-makefile.patch64
-rw-r--r--app-benchmarks/stress-ng/metadata.xml20
-rw-r--r--app-benchmarks/stress-ng/stress-ng-0.09.33.ebuild28
4 files changed, 116 insertions, 0 deletions
diff --git a/app-benchmarks/stress-ng/Manifest b/app-benchmarks/stress-ng/Manifest
new file mode 100644
index 000000000000..7b1a8889ad2c
--- /dev/null
+++ b/app-benchmarks/stress-ng/Manifest
@@ -0,0 +1,4 @@
+AUX stress-ng-0.09.31-makefile.patch 1860 BLAKE2B a5fe82d643f79fd74303de3528a25444914e0071d9e43519c567a38c6f7956bafac3b48b12ed4d74abec9494fec70521a7e1e065905651de979f0051a6ade6ef SHA512 87fde07ed850f5761fd73bb147dd0d0a0781f190dd20d9cbfcc79013c5c8c3e5c1b1217f5dc20b596c9a8482b209f2855fbde73984249b156154eb87df273f86
+DIST stress-ng-0.09.33.tar.xz 354140 BLAKE2B 301af9eb7b805619d2e91af205e6b8e1e47fc24de0b99409627a0d0b7b09d3512fab27f4b89676ffc298bb9ee86074518c919016b389e88dfe0e571ace6df397 SHA512 2add6dd17e64c7a324143f00a1e42fc3070448575bf3b65a1a4d0d261748546410d1c024ec4320249600e0c99867bfb42bbac987f297d080802ce9977240efd7
+EBUILD stress-ng-0.09.33.ebuild 679 BLAKE2B d3489ae39f79b3a064b6ccdd7bab945e1e7c2d8447ad9ebe13b405cfb21d769fa57a1e2c987429546dcfdc232905661bf7b0c5ca5fe907bee3a1619c9457a2e6 SHA512 abaa37e711a7748dab9a501fb487e634b2560aa781545cccb4f0714efd90002d4659b93601c508b98832fd2d8526ab7bf3a47f12035131cb9102b80f4bf913d7
+MISC metadata.xml 796 BLAKE2B 746809bd51f5512246e29a1e15d9b41f3cf0df968b2e2655dcaef7bb839aff27ce2cefd4818e79fec18b9f12c7902bdd0440c634f9480da2352108950554d636 SHA512 47472bafada342a449ad7d3632c2b0859ee56f2eef31ca3ca9e7af1e106126ec7858862c67baa6b8d16611e2dd3ac166ecd931bab3491c875088e4bd66499aa6
diff --git a/app-benchmarks/stress-ng/files/stress-ng-0.09.31-makefile.patch b/app-benchmarks/stress-ng/files/stress-ng-0.09.31-makefile.patch
new file mode 100644
index 000000000000..633c6db1b3fd
--- /dev/null
+++ b/app-benchmarks/stress-ng/files/stress-ng-0.09.31-makefile.patch
@@ -0,0 +1,64 @@
+--- a/Makefile 2018-06-21 15:39:27.000000000 +0200
++++ b/Makefile 2018-06-24 14:46:41.773596760 +0200
+@@ -21,7 +21,7 @@
+ # Codename "portable pressure producer"
+ #
+
+-CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -O2 -std=gnu99
++CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -std=gnu99
+
+ #
+ # Pedantic flags
+@@ -319,12 +319,10 @@
+ .o: stress-ng.h Makefile
+
+ .c.o: stress-ng.h Makefile $(SRC)
+- @echo "CC $<"
+- @$(CC) $(CFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) -c -o $@ $<
+
+ stress-ng: info $(OBJS)
+- @echo "LD $@"
+- @$(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -lc -o $@
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -lc -o $@
+ @sync
+
+ .PHONY: info
+@@ -344,8 +342,7 @@
+ sed '$$ s/.$$//' >> apparmor-data.c
+ @echo "};" >> apparmor-data.c
+ @echo "const size_t g_apparmor_data_len = sizeof(g_apparmor_data);" >> apparmor-data.c
+- @echo "CC $<"
+- @$(CC) -c apparmor-data.c -o apparmor-data.o
++ $(CC) -c apparmor-data.c -o apparmor-data.o
+ @rm -rf apparmor-data.c apparmor-data.bin
+
+ #
+@@ -360,12 +357,10 @@
+ perf.o: perf.c perf-event.c
+ @$(CC) $(CFLAGS) -E perf-event.c | grep "PERF_COUNT" | sed 's/,/ /' | \
+ awk {'print "#define _SNG_" $$1 " (1)"'} > perf-event.h
+- @echo CC $<
+- @$(CC) $(CFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) -c -o $@ $<
+
+ stress-vecmath.o: stress-vecmath.c
+- @echo CC $<
+- @$(CC) $(CFLAGS) -fno-builtin -c -o $@ $<
++ $(CC) $(CFLAGS) -fno-builtin -c -o $@ $<
+ @touch stress-ng.c
+
+ $(OBJS): stress-ng.h Makefile
+@@ -405,10 +400,10 @@
+ STRESS_NG=./stress-ng debian/tests/fast-test-all
+
+ .PHONY: install
+-install: stress-ng stress-ng.1.gz
++install: stress-ng
+ mkdir -p ${DESTDIR}${BINDIR}
+ cp stress-ng ${DESTDIR}${BINDIR}
+ mkdir -p ${DESTDIR}${MANDIR}
+- cp stress-ng.1.gz ${DESTDIR}${MANDIR}
++ cp stress-ng.1 ${DESTDIR}${MANDIR}
+ mkdir -p ${DESTDIR}${JOBDIR}
+ cp -rp example-jobs/*.job ${DESTDIR}${JOBDIR}
diff --git a/app-benchmarks/stress-ng/metadata.xml b/app-benchmarks/stress-ng/metadata.xml
new file mode 100644
index 000000000000..2fbf8ab09005
--- /dev/null
+++ b/app-benchmarks/stress-ng/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Stress-ng will stress test a computer system in various selectable ways.
+ It was designed to exercise various physical subsystems of a computer
+ as well as the various operating system kernel interfaces.
+ It features 200 stress tests, 70 CPU specific stress tests,
+ that exercise floating point, integer, bit manipulation and control flow
+ and over 20 virtual memory stress tests.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-benchmarks/stress-ng/stress-ng-0.09.33.ebuild b/app-benchmarks/stress-ng/stress-ng-0.09.33.ebuild
new file mode 100644
index 000000000000..728b7fb84338
--- /dev/null
+++ b/app-benchmarks/stress-ng/stress-ng-0.09.33.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Stress test for a computer system with various selectable ways"
+HOMEPAGE="http://kernel.ubuntu.com/~cking/stress-ng/"
+SRC_URI="http://kernel.ubuntu.com/~cking/tarballs/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/libaio
+ dev-libs/libbsd
+ dev-libs/libgcrypt:0=
+ net-misc/lksctp-tools
+ sys-apps/attr
+ sys-apps/keyutils
+ sys-libs/libapparmor
+ sys-libs/libcap
+ sys-libs/zlib:="
+
+RDEPEND="${DEPEND}"
+
+DOCS=( "README" "README.Android" "TODO" "syscalls.txt" )
+
+PATCHES=( "${FILESDIR}/${PN}-0.09.31-makefile.patch" )