summaryrefslogtreecommitdiff
path: root/app-benchmarks/httperf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
commit73c318acdaf6f8309d68bd266051e6dd1f1bd787 (patch)
tree2878053f3e7faed19a1f82c733d3bd29df69991e /app-benchmarks/httperf
parent2018227e9344edb9da15fc6a4a8298086cc2aa77 (diff)
gentoo resync : 08.06.2019
Diffstat (limited to 'app-benchmarks/httperf')
-rw-r--r--app-benchmarks/httperf/Manifest2
-rw-r--r--app-benchmarks/httperf/files/httperf-0.9.1_p20181111-libressl.patch49
-rw-r--r--app-benchmarks/httperf/httperf-0.9.1_p20181111-r1.ebuild42
3 files changed, 93 insertions, 0 deletions
diff --git a/app-benchmarks/httperf/Manifest b/app-benchmarks/httperf/Manifest
index ca0df58dcae2..e97e10e79546 100644
--- a/app-benchmarks/httperf/Manifest
+++ b/app-benchmarks/httperf/Manifest
@@ -1,3 +1,5 @@
+AUX httperf-0.9.1_p20181111-libressl.patch 1907 BLAKE2B 7a4c3d3b11d41c994dc1b098a03511dab22cf7ca649047d4af4fac4a8333fbad83f048352fb21f233d89d2c389592821680bbc223dc188cd3ae3ceb8ef9adad5 SHA512 d4893c719b16271fa09b1fe19f5a3be13b44578d60d64cb9ab62d1c49eee47720297a501e19dc4521025d117e1b2043dae20bf6c752a16c0b061de828dfdb679
DIST httperf-0.9.1_p20181111.tar.gz 107070 BLAKE2B 044f45b0d4b17bc714a718835be1e713092fe7f6d6573df237ba87791e5783e8f60d1218f29e01473ccdeec3b461d3ab7d35d68a1037ee693865a37fd78b7ea5 SHA512 34cc92f3de6d1dadc3fedc5b5f617538b76787496f9dd28b7800866abaf96c7410765d4bb0989000910bf2b51433292c0a7009fe64ba4fd29889ce96cc4d10fc
+EBUILD httperf-0.9.1_p20181111-r1.ebuild 921 BLAKE2B fe145b72aecb61b52c3e7fb3ce098daead417280d127e02ef0829083fad2c6c04cdc940752645a01380e6d9f28483bb915f4992a5effa4087ee547c224899c25 SHA512 b09f58c353e11b84be8a54bdd680cf7a82cfa26615b1ea2fd973d4497f5cf728d185c2b66c06432bca44df833e3f508ee45627633d02afceb06cc22f85e894c5
EBUILD httperf-0.9.1_p20181111.ebuild 872 BLAKE2B 6c782cb5e5c5ed0cafb8c9143639025397e4f06cbddf136eb8d3c759585b2a0ce4328c73f358a9e29b90d2f1c38c9099fd500ed1d7f3fd368c0b16e99cb035a7 SHA512 30ebefb5b74f7d1e668f2c224e15f1385227914bcf1534ff9777f5324c22235999d051a7562b960dcbcb632dc9a2f3b5965dda9aeb713a7b507641ccaacef3b9
MISC metadata.xml 1011 BLAKE2B 3254dacb03b6a957106287289566d9aa466768b5449eee054c423f2d22aac5cc464f990a7afa101256cb40075b03404c4af8bee542e6ee01b5af58e7c8a8415b SHA512 86a8ef9ea287532d89d5833abf29d71aae7e9aca494d6e40ebd6f43cb0eb766e63b769bc2218f8e374f13045d2b3445283dac68d384d9fb449e5a0800caf1dfb
diff --git a/app-benchmarks/httperf/files/httperf-0.9.1_p20181111-libressl.patch b/app-benchmarks/httperf/files/httperf-0.9.1_p20181111-libressl.patch
new file mode 100644
index 000000000000..e1c0c90fac07
--- /dev/null
+++ b/app-benchmarks/httperf/files/httperf-0.9.1_p20181111-libressl.patch
@@ -0,0 +1,49 @@
+From 1c4277eb9288c719b009aacb4bd71ca543f51cbd Mon Sep 17 00:00:00 2001
+From: Stefan Strogin <steils@gentoo.org>
+Date: Mon, 3 Jun 2019 16:18:21 +0300
+Subject: [PATCH] Use correct ifdefs for checking TLS 1.3
+
+TLS 1.3 is not ready yet in LibreSSL. Also there is a theoretical
+possibility of OpenSSL >=1.1.1 built without TLS 1.3 support
+
+Upstream-Status: Submitted
+[https://github.com/httperf/httperf/pull/66]
+Signed-off-by: Stefan Strogin <steils@gentoo.org>
+---
+ src/httperf.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/httperf.c b/src/httperf.c
+index af6f568..5dbba07 100755
+--- a/src/httperf.c
++++ b/src/httperf.c
+@@ -687,7 +687,7 @@ main(int argc, char **argv)
+ param.ssl_protocol = 5;
+ else if (strcasecmp (optarg, "TLSv1.2") == 0 || strcasecmp (optarg, "TLSv1_2") == 0)
+ param.ssl_protocol = 6;
+-#if (OPENSSL_VERSION_NUMBER >= 0x10101000L)
++#ifdef TLS1_3_VERSION
+ else if (strcasecmp (optarg, "TLSv1.3") == 0 || strcasecmp (optarg, "TLSv1_3") == 0)
+ param.ssl_protocol = 7;
+ #endif
+@@ -1104,7 +1104,7 @@ main(int argc, char **argv)
+ SSL_CTX_set_options(ssl_ctx, SSL_OP_NO_SSLv2 | SSL_OP_NO_SSLv3 | SSL_OP_NO_TLSv1 | SSL_OP_NO_TLSv1_1); break;
+ #endif
+
+-#if (OPENSSL_VERSION_NUMBER >= 0x10101000L)
++#ifdef TLS1_3_VERSION
+ /* 7/TLSv1.3 */
+ case 7:
+ ssl_ctx = SSL_CTX_new (TLS_client_method ());
+@@ -1329,7 +1329,7 @@ main(int argc, char **argv)
+ case 4: printf (" --ssl-protocol=TLSv1.0"); break;
+ case 5: printf (" --ssl-protocol=TLSv1.1"); break;
+ case 6: printf (" --ssl-protocol=TLSv1.2"); break;
+-#if (OPENSSL_VERSION_NUMBER >= 0x10101000L)
++#ifdef TLS1_3_VERSION
+ case 7: printf (" --ssl-protocol=TLSv1.3"); break;
+ #endif
+ }
+--
+2.21.0
+
diff --git a/app-benchmarks/httperf/httperf-0.9.1_p20181111-r1.ebuild b/app-benchmarks/httperf/httperf-0.9.1_p20181111-r1.ebuild
new file mode 100644
index 000000000000..d340a5ce8237
--- /dev/null
+++ b/app-benchmarks/httperf/httperf-0.9.1_p20181111-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT="00bf5dab6fd284aa559f125964f5fe6dc0f23595"
+inherit autotools
+
+DESCRIPTION="A tool from HP for measuring web server performance"
+HOMEPAGE="https://github.com/httperf/httperf"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~amd64-linux ~x64-macos"
+IUSE="debug idleconn libressl"
+
+DEPEND="
+ idleconn? ( dev-libs/libevent:0= )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+PATCHES=( "${FILESDIR}"/${P}-libressl.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/usr/bin
+ $(use_enable debug)
+ $(use_enable idleconn)
+ )
+
+ econf "${myeconfargs[@]}"
+}