summaryrefslogtreecommitdiff
path: root/app-benchmarks/geekbench/geekbench-4.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /app-benchmarks/geekbench/geekbench-4.4.1.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'app-benchmarks/geekbench/geekbench-4.4.1.ebuild')
-rw-r--r--app-benchmarks/geekbench/geekbench-4.4.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-benchmarks/geekbench/geekbench-4.4.1.ebuild b/app-benchmarks/geekbench/geekbench-4.4.1.ebuild
new file mode 100644
index 000000000000..5754046d5dcc
--- /dev/null
+++ b/app-benchmarks/geekbench/geekbench-4.4.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A Cross-Platform Benchmark for Android, iOS, Linux, MacOS and Windows"
+HOMEPAGE="https://www.geekbench.com"
+SRC_URI="https://cdn.geekbench.com/Geekbench-${PV}-Linux.tar.gz"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="geekbench"
+SLOT="4"
+
+RESTRICT="bindist fetch mirror strip"
+
+S="${WORKDIR}/Geekbench-${PV}-Linux"
+
+QA_PREBUILT="
+ opt/geekbench4/geekbench4
+ opt/geekbench4/geekbench_x86_32
+ opt/geekbench4/geekbench_x86_64
+"
+
+pkg_nofetch() {
+ elog "Please download ${A} from ${HOMEPAGE}/download/linux"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_install() {
+ exeinto /opt/geekbench4
+ doexe geekbench4 geekbench_x86_32 geekbench_x86_64
+
+ insinto /opt/geekbench4
+ doins geekbench.plar
+
+ dodir /opt/bin
+ dosym ../geekbench4/geekbench4 /opt/bin/geekbench4
+}
+
+pkg_postinst() {
+ elog "If you have purchased a commercial license, you can enter"
+ elog "your email address and your license key with the following command:"
+ elog "geekbench4 -r <email address> <license key>"
+}