summaryrefslogtreecommitdiff
path: root/app-benchmarks/contest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-benchmarks/contest
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-benchmarks/contest')
-rw-r--r--app-benchmarks/contest/Manifest5
-rw-r--r--app-benchmarks/contest/contest-0.61-r1.ebuild37
-rw-r--r--app-benchmarks/contest/files/contest-0.61-fix-buildsystem.patch22
-rw-r--r--app-benchmarks/contest/files/contest-fortify_sources.patch11
-rw-r--r--app-benchmarks/contest/metadata.xml5
5 files changed, 80 insertions, 0 deletions
diff --git a/app-benchmarks/contest/Manifest b/app-benchmarks/contest/Manifest
new file mode 100644
index 000000000000..75295b15e0b0
--- /dev/null
+++ b/app-benchmarks/contest/Manifest
@@ -0,0 +1,5 @@
+AUX contest-0.61-fix-buildsystem.patch 581 BLAKE2B 9a11fb9b24a674a7bea0c40b9100fa3813954b853cd133cf69b90b0a3381a20ef289793939834c777140709082b262715990900af16c422442fc2215be2922f2 SHA512 35abe08432d62020a1c9daa2c9bae18dd2d8db99d3f938f9eb423d89b30c9d67441922bef5376c9e4b5be1744fb62b6e7c0163033f006225638f95c097f484a3
+AUX contest-fortify_sources.patch 376 BLAKE2B fb2ca7869fc19304c14aa2e52e0d3986f2021703800f547af5f88b866978a016e82b2e2911192465d7836bbbc297ab25f7d7d3499759ee9ff915ee28a2e0e089 SHA512 71bb1d0b594bfa2342622c5495ea0306829ced109fd606bdfb5e1aecc17b11270235f83606961067819097863ba3bff66e5c37c5496028ccce3f1701ee9bdb2f
+DIST contest-0.61.tar.bz2 29204 BLAKE2B 76e19365026b63f4a37c45905769f28c921455cb4020666898efa332d88627d85e5044f385556f07325537b6b4f80079b301fd9915f068754dd80d815092ff86 SHA512 34fb83a3b37d67d9729ce14fdd066010c7360a401d21f3566be8dae7271a30f01cc5b84092405ddfb6961a2284af0a18ce6709ab6d4ab68607aa98f975815131
+EBUILD contest-0.61-r1.ebuild 752 BLAKE2B 1c3960f311cf6b0f4cd68bc28b503d663dd8976f319eb264e6ce8f71230c495af782ce6fe701302dd5045e55617a36d68bcd32794eb3199af96daabe8ec0b697 SHA512 f81082c98be91b791686bf0688706129bb149260021b5acf4f24ec998eddcd1c0059b369528996c8370b8feca5d512b259fb9813ec5c51599efec353216b3119
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-benchmarks/contest/contest-0.61-r1.ebuild b/app-benchmarks/contest/contest-0.61-r1.ebuild
new file mode 100644
index 000000000000..a2254a708dd5
--- /dev/null
+++ b/app-benchmarks/contest/contest-0.61-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Test system responsiveness to compare different kernels"
+HOMEPAGE="http://users.tpg.com.au/ckolivas/contest/"
+SRC_URI="http://www.tux.org/pub/kernel/people/ck/apps/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND=">=app-benchmarks/dbench-2.0"
+PATCHES=(
+ "${FILESDIR}/${PN}-fortify_sources.patch"
+ "${FILESDIR}/${P}-fix-buildsystem.patch"
+)
+
+src_prepare () {
+ # fix #570250 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+
+ default
+ tc-export CC
+}
+src_compile() {
+ emake
+}
+
+src_install() {
+ dobin contest
+ doman contest.1
+ dodoc README
+}
diff --git a/app-benchmarks/contest/files/contest-0.61-fix-buildsystem.patch b/app-benchmarks/contest/files/contest-0.61-fix-buildsystem.patch
new file mode 100644
index 000000000000..7e8c6b7eb6a2
--- /dev/null
+++ b/app-benchmarks/contest/files/contest-0.61-fix-buildsystem.patch
@@ -0,0 +1,22 @@
+--- contest-0.61/Makefile
++++ contest-0.61/Makefile
+@@ -1,8 +1,8 @@
+ INSTPATH=/usr
+ BIN=$(INSTPATH)/bin
+ MAN=$(INSTPATH)/man
+-CC=gcc
+-CFLAGS= -W -Wall -Wpointer-arith -Wmissing-prototypes -Wmissing-declarations \
++CC?=gcc
++CFLAGS?= -W -Wall -Wpointer-arith -Wmissing-prototypes -Wmissing-declarations \
+ -g -O2
+
+ ifeq ($(shell uname),FreeBSD)
+@@ -14,7 +14,7 @@
+ list_load.o
+
+ contest: $(objs)
+- $(CC) $(CFLAGS) -o $@ $(objs) $(KVM)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $(objs) $(KVM)
+ contest.1.gz: contest.1
+ gzip -c contest.1 > contest.1.gz
+ install: contest contest.1.gz
diff --git a/app-benchmarks/contest/files/contest-fortify_sources.patch b/app-benchmarks/contest/files/contest-fortify_sources.patch
new file mode 100644
index 000000000000..042065822612
--- /dev/null
+++ b/app-benchmarks/contest/files/contest-fortify_sources.patch
@@ -0,0 +1,11 @@
+--- contest-0.61/bmark.c 2009-02-27 23:13:44.000000000 +0000
++++ contest-0.61/bmark.c 2009-02-27 23:12:44.000000000 +0000
+@@ -47,7 +47,7 @@
+ }
+ /* child */
+
+- if((tmpfd=open(TMP_FILE, O_RDWR|O_CREAT|O_TRUNC))==-1){
++ if((tmpfd=open(TMP_FILE, O_RDWR|O_CREAT|O_TRUNC, S_IRUSR|S_IWUSR))==-1){
+ printsys("Could not open temporary file\n");
+ }
+ if(dup2(tmpfd, TMP_FD)==-1){
diff --git a/app-benchmarks/contest/metadata.xml b/app-benchmarks/contest/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-benchmarks/contest/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>