summaryrefslogtreecommitdiff
path: root/app-backup/zbackup/zbackup-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-backup/zbackup/zbackup-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-backup/zbackup/zbackup-9999.ebuild')
-rw-r--r--app-backup/zbackup/zbackup-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-backup/zbackup/zbackup-9999.ebuild b/app-backup/zbackup/zbackup-9999.ebuild
new file mode 100644
index 000000000000..e199603c64d9
--- /dev/null
+++ b/app-backup/zbackup/zbackup-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="A versatile deduplicating backup tool"
+HOMEPAGE="http://zbackup.org/ https://github.com/zbackup/zbackup"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+
+LICENSE="GPL-2+-with-openssl-exception"
+KEYWORDS=""
+SLOT="0"
+IUSE="libressl tartool"
+
+DEPEND="app-arch/lzma
+ dev-libs/lzo:2
+ <dev-libs/protobuf-3:0=
+ sys-libs/libunwind:7
+ sys-libs/zlib
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+RDEPEND="${DEPEND}"
+
+# Add tartool build
+PATCHES=( "${FILESDIR}/${P}-tartool.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TARTOOL="$(usex tartool)"
+ )
+
+ cmake-utils_src_configure
+}