summaryrefslogtreecommitdiff
path: root/app-backup/vzdump/vzdump-1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /app-backup/vzdump/vzdump-1.2-r1.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'app-backup/vzdump/vzdump-1.2-r1.ebuild')
-rw-r--r--app-backup/vzdump/vzdump-1.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-backup/vzdump/vzdump-1.2-r1.ebuild b/app-backup/vzdump/vzdump-1.2-r1.ebuild
new file mode 100644
index 000000000000..24171295d3e1
--- /dev/null
+++ b/app-backup/vzdump/vzdump-1.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-functions
+
+DESCRIPTION="A utility to make consistent snapshots of running OpenVZ containers"
+HOMEPAGE="http://pve.proxmox.com/wiki/VZDump"
+SRC_URI="http://www.proxmox.com/cms_proxmox/cms/upload/vzdump/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-lang/perl:="
+RDEPEND="${DEPEND}
+ app-misc/cstream
+ dev-perl/LockFile-Simple
+ net-misc/rsync
+ sys-cluster/vzctl
+ sys-fs/lvm2
+ virtual/mta
+ virtual/perl-Getopt-Long"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2-no-compress.patch
+)
+
+src_compile() {
+ return
+}
+
+src_install() {
+ emake PERLLIBDIR="$(perl_get_vendorlib)/PVE" DESTDIR="${D}" install
+ einstalldocs
+}