summaryrefslogtreecommitdiff
path: root/app-backup/tob/tob-0.26-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-backup/tob/tob-0.26-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-backup/tob/tob-0.26-r2.ebuild')
-rw-r--r--app-backup/tob/tob-0.26-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-backup/tob/tob-0.26-r2.ebuild b/app-backup/tob/tob-0.26-r2.ebuild
new file mode 100644
index 000000000000..ca568a113f3a
--- /dev/null
+++ b/app-backup/tob/tob-0.26-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A general driver for making and maintaining backups"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="app-arch/afio"
+DEPEND=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-no-maketemp-warn.diff \
+ "${FILESDIR}"/${P}-nice.patch \
+ "${FILESDIR}"/${P}-scsi-tape.diff
+ ecvs_clean
+}
+
+src_install() {
+ dosbin tob
+ dodir /var/lib/tob
+ insinto /etc/tob
+ doins tob.rc
+ insinto /etc/tob/volumes
+ doins example.*
+
+ dodoc -r README contrib/tobconv doc sample-rc
+ doman tob.8
+}