summaryrefslogtreecommitdiff
path: root/app-backup/synology-cloud-station-backup/synology-cloud-station-backup-4450.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /app-backup/synology-cloud-station-backup/synology-cloud-station-backup-4450.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'app-backup/synology-cloud-station-backup/synology-cloud-station-backup-4450.ebuild')
-rw-r--r--app-backup/synology-cloud-station-backup/synology-cloud-station-backup-4450.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-backup/synology-cloud-station-backup/synology-cloud-station-backup-4450.ebuild b/app-backup/synology-cloud-station-backup/synology-cloud-station-backup-4450.ebuild
new file mode 100644
index 000000000000..0e67bbf426c0
--- /dev/null
+++ b/app-backup/synology-cloud-station-backup/synology-cloud-station-backup-4450.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg
+
+SVER="4.3.2"
+
+DESCRIPTION="Back up your files from multiple client computers to a centralized Synology NAS"
+HOMEPAGE="https://www.synology.com/en-global/releaseNote/CloudStationBackup"
+SRC_URI="
+ amd64? ( https://global.download.synology.com/download/Tools/CloudStationBackup/${SVER}-${PV}/Ubuntu/Installer/x86_64/synology-cloud-station-backup-${PV}.x86_64.deb )
+ x86? ( https://global.download.synology.com/download/Tools/CloudStationBackup/${SVER}-${PV}/Ubuntu/Installer/i686/synology-cloud-station-backup-${PV}.i686.deb )
+"
+
+LICENSE="Synology"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+RESTRICT="bindist mirror strip"
+S="${WORKDIR}"
+
+src_unpack() {
+ default
+ unpack "${WORKDIR}"/data.tar.xz
+
+ # Allow provided docs are useless
+ rm -r usr/share/doc || die
+}
+
+src_install() {
+ insinto /
+ doins -r opt/
+ doins -r usr/
+
+ # Fix permissions
+ chmod +x "${ED}"/usr/bin/* || die
+ chmod +x "${ED}"/opt/Synology/CloudStationBackup/bin/* || die
+}