summaryrefslogtreecommitdiff
path: root/app-backup/snapper/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /app-backup/snapper/files
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'app-backup/snapper/files')
-rw-r--r--app-backup/snapper/files/snapper-0.5.6-swap.patch36
-rw-r--r--app-backup/snapper/files/snapper-0.9.0-testsuite.patch83
2 files changed, 83 insertions, 36 deletions
diff --git a/app-backup/snapper/files/snapper-0.5.6-swap.patch b/app-backup/snapper/files/snapper-0.5.6-swap.patch
deleted file mode 100644
index aa24330d7304..000000000000
--- a/app-backup/snapper/files/snapper-0.5.6-swap.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-commit 22bc1d808ebb6c3958e8231a36b73cd45a7f2c30
-Author: Spencer Janssen <spencerjanssen@gmail.com>
-Date: Mon Dec 3 17:33:49 2018 -0600
-
- Work around btrfs v4.19
-
- Addresses #459
-
-diff --git a/snapper/Btrfs.cc b/snapper/Btrfs.cc
-index cb9f7b3..c05557b 100644
---- a/snapper/Btrfs.cc
-+++ b/snapper/Btrfs.cc
-@@ -41,6 +41,9 @@
- #include <btrfs/send.h>
- #include <btrfs/send-stream.h>
- #include <btrfs/send-utils.h>
-+#ifdef swap
-+#undef swap
-+#endif
- #include <boost/version.hpp>
- #include <boost/thread.hpp>
- #endif
-diff --git a/snapper/BtrfsUtils.cc b/snapper/BtrfsUtils.cc
-index bada3f8..9edc325 100644
---- a/snapper/BtrfsUtils.cc
-+++ b/snapper/BtrfsUtils.cc
-@@ -34,6 +34,9 @@
- #ifdef HAVE_LIBBTRFS
- #include <btrfs/ioctl.h>
- #include <btrfs/send-utils.h>
-+#ifdef swap
-+#undef swap
-+#endif
- #endif
- #include <algorithm>
- #include <functional>
diff --git a/app-backup/snapper/files/snapper-0.9.0-testsuite.patch b/app-backup/snapper/files/snapper-0.9.0-testsuite.patch
new file mode 100644
index 000000000000..7aa089569b4a
--- /dev/null
+++ b/app-backup/snapper/files/snapper-0.9.0-testsuite.patch
@@ -0,0 +1,83 @@
+diff --git a/configure.ac b/configure.ac
+index 06e4721..c89d0aa 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -86,6 +86,12 @@ AS_IF([test "x$with_conf" != xno], [SYSCONFIG="${with_conf}"])
+
+ CPPFLAGS="${CPPFLAGS} -DCONF_DIR='\"${SYSCONFIG}\"'"
+
++AC_ARG_ENABLE([tests], AC_HELP_STRING([--disable-tests],[Disable internal tests support]),
++ [with_tests=$enableval],[with_tests=yes])
++AM_CONDITIONAL(ENABLE_TESTS, [test "x$with_tests" = "xyes"])
++if test "x$with_tests" = "xyes"; then
++ AC_DEFINE(ENABLE_TESTS, 1, [Enable internal tests support])
++fi
+
+ AC_ARG_ENABLE([btrfs], AC_HELP_STRING([--disable-btrfs],[Disable Btrfs internal snapshots support]),
+ [with_btrfs=$enableval],[with_btrfs=yes])
+diff --git a/testsuite-cmp/Makefile.am b/testsuite-cmp/Makefile.am
+index 81104bf..9c29477 100644
+--- a/testsuite-cmp/Makefile.am
++++ b/testsuite-cmp/Makefile.am
+@@ -2,6 +2,7 @@
+ # Makefile.am for snapper/testsuite-cmp
+ #
+
++if ENABLE_TESTS
+ AM_CPPFLAGS = -I$(top_srcdir)
+ AM_LDFLAGS = -lboost_system
+
+@@ -15,3 +16,4 @@ cmp_SOURCES = cmp.cc
+
+ EXTRA_DIST = $(noinst_SCRIPTS)
+
++endif
+diff --git a/testsuite-real/Makefile.am b/testsuite-real/Makefile.am
+index 717313a..527843d 100644
+--- a/testsuite-real/Makefile.am
++++ b/testsuite-real/Makefile.am
+@@ -2,6 +2,7 @@
+ # Makefile.am for snapper/testsuite-real
+ #
+
++if ENABLE_TESTS
+ CXXFLAGS += -std=gnu++0x
+
+ AM_CPPFLAGS = -I$(top_srcdir)
+@@ -53,3 +54,4 @@ ug_tests_SOURCES = ug-tests.cc
+
+ EXTRA_DIST = $(test_DATA) $(test_SCRIPTS)
+
++endif
+diff --git a/testsuite/Makefile.am b/testsuite/Makefile.am
+index ccb84d3..409e265 100644
+--- a/testsuite/Makefile.am
++++ b/testsuite/Makefile.am
+@@ -2,6 +2,7 @@
+ # Makefile.am for snapper/testsuite
+ #
+
++if ENABLE_TESTS
+ AM_CPPFLAGS = -I$(top_srcdir) $(DBUS_CFLAGS)
+
+ LDADD = ../snapper/libsnapper.la ../dbus/libdbus.la -lboost_unit_test_framework
+@@ -48,3 +49,4 @@ lvm_utils_test_LDADD = -lboost_unit_test_framework ../snapper/libsnapper.la
+ range_test_LDADD = -lboost_unit_test_framework ../client/utils/libutils.la
+
+ limit_test_LDADD = -lboost_unit_test_framework ../client/utils/libutils.la
++endif
+diff --git a/zypp-plugin/testsuite/Makefile.am b/zypp-plugin/testsuite/Makefile.am
+index 7b52e13..71cb545 100644
+--- a/zypp-plugin/testsuite/Makefile.am
++++ b/zypp-plugin/testsuite/Makefile.am
+@@ -1,3 +1,5 @@
++
++if ENABLE_TESTS
+ if HAVE_ZYPP
+ TEST_LOG_DRIVER = $(SHELL) tap-driver.sh
+
+@@ -12,3 +14,4 @@ TESTS = $(check_SCRIPTS)
+
+ EXTRA_DIST = $(check_SCRIPTS) $(noinst_SCRIPTS) $(noinst_DATA) tap-driver.sh
+ endif
++endif