summaryrefslogtreecommitdiff
path: root/app-backup/restic/restic-0.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-backup/restic/restic-0.7.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-backup/restic/restic-0.7.1.ebuild')
-rw-r--r--app-backup/restic/restic-0.7.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-backup/restic/restic-0.7.1.ebuild b/app-backup/restic/restic-0.7.1.ebuild
new file mode 100644
index 000000000000..e3a29977d90f
--- /dev/null
+++ b/app-backup/restic/restic-0.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A backup program that is fast, efficient and secure"
+HOMEPAGE="https://restic.github.io/"
+SRC_URI="https://github.com/restic/restic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+DOCS=( README.rst CONTRIBUTING.md doc/design.rst doc/faq.rst doc/index.rst doc/manual.rst
+ doc/rest_backend.rst doc/development.rst doc/talks.rst doc/tutorial_aws_s3.rst doc/installation.rst )
+
+DEPEND="dev-lang/go
+ test? ( sys-fs/fuse:0 )"
+
+RDEPEND="sys-fs/fuse:0"
+
+src_compile() {
+ local mygoargs=(
+ -v
+ -work
+ -x
+ -tags release
+ -ldflags "-w -X main.version=${PV}"
+ -asmflags "-trimpath=${S}/vendor -trimpath=${S}"
+ -gcflags "-trimpath=${S}/vendor -trimpath=${S}"
+ -o "${S}"/restic cmds/restic
+ )
+
+ GOPATH="${S}:${S}/vendor" go build "${mygoargs[@]}" || die
+}
+
+src_test() {
+ GOPATH="${S}:${S}/vendor" go test -v -work -x restic/... cmds/... || die
+}
+
+src_install() {
+ dobin restic
+ einstalldocs
+}