summaryrefslogtreecommitdiff
path: root/app-backup/restic/restic-0.13.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-06 22:15:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-06 22:15:01 +0100
commit37707aeea7000a1e20d52db99ca6a70674ce89f3 (patch)
tree728ca9d62f2e6f81f9111d7fa60a96ec02653441 /app-backup/restic/restic-0.13.1.ebuild
parent5c92379e3a6732ff2855a56c60576983ae42e288 (diff)
gentoo auto-resync : 06:07:2023 - 22:15:01
Diffstat (limited to 'app-backup/restic/restic-0.13.1.ebuild')
-rw-r--r--app-backup/restic/restic-0.13.1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/app-backup/restic/restic-0.13.1.ebuild b/app-backup/restic/restic-0.13.1.ebuild
deleted file mode 100644
index a7ea04958c68..000000000000
--- a/app-backup/restic/restic-0.13.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 go-module
-
-DESCRIPTION="A backup program that is fast, efficient and secure"
-HOMEPAGE="https://restic.github.io/"
-SRC_URI="https://github.com/restic/restic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
-
-LICENSE="Apache-2.0 BSD BSD-2 LGPL-3-with-linking-exception MIT"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ~ppc64 ~riscv x86"
-IUSE=""
-
-RDEPEND="sys-fs/fuse:0"
-DEPEND="${RDEPEND}"
-
-src_compile() {
- local mygoargs=(
- -v
- -work
- -x
- -tags release
- -ldflags "-X main.version=${PV}"
- -asmflags "-trimpath=${S}"
- -gcflags "-trimpath=${S}"
- )
-
- go build "${mygoargs[@]}" -o restic ./cmd/restic || die
-}
-
-src_test() {
- go test -timeout 30m -v -work -x ./cmd/... ./internal/... || die
-}
-
-src_install() {
- dobin restic
-
- newbashcomp doc/bash-completion.sh "${PN}"
-
- insinto /usr/share/zsh/site-functions
- newins doc/zsh-completion.zsh _restic
-
- doman doc/man/*
- dodoc doc/*.rst
-}