summaryrefslogtreecommitdiff
path: root/app-backup/holland/holland-1.0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-backup/holland/holland-1.0.10.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-backup/holland/holland-1.0.10.ebuild')
-rw-r--r--app-backup/holland/holland-1.0.10.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/app-backup/holland/holland-1.0.10.ebuild b/app-backup/holland/holland-1.0.10.ebuild
deleted file mode 100644
index f7fadd3b2230..000000000000
--- a/app-backup/holland/holland-1.0.10.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Holland Core Plugins"
-HOMEPAGE="http://www.hollandbackup.org/"
-SRC_URI="http://hollandbackup.org/releases/stable/${PV%.*}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples postgres sqlite"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-RDEPEND="
- postgres? ( ~app-backup/holland-backup-pgdump-${PV}[${PYTHON_USEDEP}] )
- sqlite? ( ~app-backup/holland-backup-sqlite-${PV}[${PYTHON_USEDEP}] )
- examples? (
- ~app-backup/holland-backup-example-${PV}[${PYTHON_USEDEP}]
- ~app-backup/holland-backup-random-${PV}[${PYTHON_USEDEP}]
- )
-"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local DOCS=( README config/README config/providers/README docs/man/README docs/man/holland.rst )
- use doc && local HTML_DOCS=( docs/build/html/. )
-
- distutils-r1_python_install_all
-
- keepdir /var/log/holland
-
- keepdir /etc/holland
- keepdir /etc/holland/backupsets
- keepdir /etc/holland/providers
-
- insinto /etc/holland
- doins config/holland.conf
-
- insinto /etc/holland/backupsets
- doins config/backupsets/default.conf
-
- doman docs/man/holland.1
-}