summaryrefslogtreecommitdiff
path: root/app-backup/holland-backup-pgdump
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-backup/holland-backup-pgdump
reinit the tree, so we can have metadata
Diffstat (limited to 'app-backup/holland-backup-pgdump')
-rw-r--r--app-backup/holland-backup-pgdump/Manifest5
-rw-r--r--app-backup/holland-backup-pgdump/holland-backup-pgdump-1.0.10.ebuild38
-rw-r--r--app-backup/holland-backup-pgdump/metadata.xml5
3 files changed, 48 insertions, 0 deletions
diff --git a/app-backup/holland-backup-pgdump/Manifest b/app-backup/holland-backup-pgdump/Manifest
new file mode 100644
index 000000000000..21e11baee56b
--- /dev/null
+++ b/app-backup/holland-backup-pgdump/Manifest
@@ -0,0 +1,5 @@
+DIST holland-1.0.10.tar.gz 449334 SHA256 c893be3dc77126125334dfa9eec404d7608a78a2bf88ec1d7ddc12ad7f7ed8d1 SHA512 5183ec73012edcaba50ef5cc9b892480d5f60301d01d17bd96c5490bd8e6ae42bd21abb6084e6665317b8025489981a02293cd583964f01e86459609b93e918f WHIRLPOOL fa8934c635f4347ffc6a327f6135d61ca26805d727fe4caca32ba9c23224062492553182e24d15fc59177787241903dd3409396c176fab2d55c34e9dcc5668e3
+EBUILD holland-backup-pgdump-1.0.10.ebuild 854 SHA256 f6d3070436be679081072ccd79c072d303109802059d4b223816286ee516ba2c SHA512 6403157e9f8ccd422f1e035f48048989030108469379045dfce187974846db92d8181df4f3bc8b904a787c1b692f101d950edf305284285cc7e9e906bf38e4ba WHIRLPOOL d3f514aa779f8e9ca5ce5d466cca51916311ee3d9a5df1d23bed5fbabeed1d827f6cb8f954f28a6c8d8666f0c7fe76667d5d5e00785f57c0fc5e54f0302f73d5
+MISC ChangeLog 2351 SHA256 a1582beece0c28b766ae38cdd9586c9fa1012fd9c55d8868214f6d74cff77ad4 SHA512 b4179b351dac24055ee07a84263a42a3fd8b61fd1e75638d60e1e7a34526d023d39d9b6038f48254212982f85c52fe77d0de18011705cf96680d0d26c7300020 WHIRLPOOL fd89c1c3c8bd65b4056b7229343b72d1022de5cfea7371831fe88dafcd0f031f624419a52047520c94008f5e41d70a7a94555a672d521ce2bf6cf4be2cdf0213
+MISC ChangeLog-2015 442 SHA256 f38633317181d2adb909c05d9806f343ecbf1d4aee1be52fcaf98c606783428d SHA512 bbc209016a4d42dc0d8a4eddc5b63760519e01ab245a4f42b70403c440a9b08b025c3c434cb01e26aee116563d6f94b486d71801d33f56a5639d876fd21d49c9 WHIRLPOOL 4f468da6d523346468f54bfc6696530e490c1b0a9b940240f2e660e4f0380368049d650a0d2cb42dc6a6a588448aff27566335058ac6d333175034960b2df017
+MISC metadata.xml 167 SHA256 5fe493e76bba84455c54b3a46adfae5a1bfe01c764ef0d9e5f6d3e8a1d142188 SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33 WHIRLPOOL dc6c3dfc7fd7f0d76c97f0786cb76a55b8564f8437f96d4ccebf985817b9f6dcc4c61830aa5df80d725e4a54b281ea2e03d6b0859214af081112cba15025e64b
diff --git a/app-backup/holland-backup-pgdump/holland-backup-pgdump-1.0.10.ebuild b/app-backup/holland-backup-pgdump/holland-backup-pgdump-1.0.10.ebuild
new file mode 100644
index 000000000000..63609d1a9966
--- /dev/null
+++ b/app-backup/holland-backup-pgdump/holland-backup-pgdump-1.0.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Holland pgdump Plugin"
+HOMEPAGE="http://www.hollandbackup.org/"
+
+MY_P="${P%%-*}-${P##*-}"
+
+SRC_URI="http://hollandbackup.org/releases/stable/${PV%.*}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ ~app-backup/holland-lib-common-${PV}[${PYTHON_USEDEP}]
+ dev-python/psycopg[${PYTHON_USEDEP}]
+"
+PDEPEND="~app-backup/holland-${PV}[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}/plugins/${PN//-/.}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ keepdir /etc/holland
+ keepdir /etc/holland/providers
+
+ insinto /etc/holland/providers
+ doins "${S}"/../../config/providers/${PN##*-}.conf
+}
diff --git a/app-backup/holland-backup-pgdump/metadata.xml b/app-backup/holland-backup-pgdump/metadata.xml
new file mode 100644
index 000000000000..7a38bb900964
--- /dev/null
+++ b/app-backup/holland-backup-pgdump/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+</pkgmetadata>