summaryrefslogtreecommitdiff
path: root/app-backup/duplicity/duplicity-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-30 22:09:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-30 22:09:29 +0100
commit5685192438444645b599ae1b567d1b73103fba7f (patch)
treeb97cf1e8b3b15e1fa0748329b14d9d83a71d7a4c /app-backup/duplicity/duplicity-2.1.0.ebuild
parente744ca7502c41cb37fe777c783aa029707910f21 (diff)
gentoo auto-resync : 30:08:2023 - 22:09:29
Diffstat (limited to 'app-backup/duplicity/duplicity-2.1.0.ebuild')
-rw-r--r--app-backup/duplicity/duplicity-2.1.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-backup/duplicity/duplicity-2.1.0.ebuild b/app-backup/duplicity/duplicity-2.1.0.ebuild
new file mode 100644
index 000000000000..003ceb5ad3d3
--- /dev/null
+++ b/app-backup/duplicity/duplicity-2.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_10 python3_11 )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="https://duplicity.gitlab.io/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto3[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs-cmd.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}