summaryrefslogtreecommitdiff
path: root/app-backup/dirvish/dirvish-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-backup/dirvish/dirvish-1.2.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-backup/dirvish/dirvish-1.2.1.ebuild')
-rw-r--r--app-backup/dirvish/dirvish-1.2.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-backup/dirvish/dirvish-1.2.1.ebuild b/app-backup/dirvish/dirvish-1.2.1.ebuild
new file mode 100644
index 000000000000..13f3e8b769af
--- /dev/null
+++ b/app-backup/dirvish/dirvish-1.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Dirvish is a fast, disk based, rotating network backup system"
+HOMEPAGE="http://www.dirvish.org/"
+SRC_URI="http://dirvish.org/${P}.tgz"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="app-arch/tar"
+RDEPEND="dev-perl/Time-ParseDate
+ dev-perl/Time-Period
+ >=net-misc/rsync-2.5.7"
+
+src_prepare() {
+ default
+
+ local f
+ for f in dirvish dirvish-runall dirvish-expire dirvish-locate; do
+ cat > $f <<-EOF || die
+ #!/usr/bin/perl
+
+ \$CONFDIR = "/etc/dirvish";
+
+ EOF
+ cat $f.pl >> $f || die
+ cat loadconfig.pl >> $f || die
+ done
+}
+
+src_install() {
+ dosbin dirvish dirvish-runall dirvish-expire dirvish-locate
+ doman dirvish.8 dirvish-runall.8 dirvish-expire.8 dirvish-locate.8 dirvish.conf.5
+
+ HTML_DOCS=( {FAQ,RELEASE,TODO}.html )
+ einstalldocs
+
+ insinto /etc/dirvish
+ doins "${FILESDIR}"/master.conf.example
+}