summaryrefslogtreecommitdiff
path: root/app-backup/dirvish/dirvish-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-backup/dirvish/dirvish-1.2.1.ebuild
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-backup/dirvish/dirvish-1.2.1.ebuild')
-rw-r--r--app-backup/dirvish/dirvish-1.2.1.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/app-backup/dirvish/dirvish-1.2.1.ebuild b/app-backup/dirvish/dirvish-1.2.1.ebuild
index 57629ae47577..13f3e8b769af 100644
--- a/app-backup/dirvish/dirvish-1.2.1.ebuild
+++ b/app-backup/dirvish/dirvish-1.2.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
DESCRIPTION="Dirvish is a fast, disk based, rotating network backup system"
HOMEPAGE="http://www.dirvish.org/"
SRC_URI="http://dirvish.org/${P}.tgz"
@@ -15,24 +17,29 @@ RDEPEND="dev-perl/Time-ParseDate
dev-perl/Time-Period
>=net-misc/rsync-2.5.7"
-src_compile() {
- for f in dirvish dirvish-runall dirvish-expire dirvish-locate ; do
- cat > $f <<-EOF
+src_prepare() {
+ default
+
+ local f
+ for f in dirvish dirvish-runall dirvish-expire dirvish-locate; do
+ cat > $f <<-EOF || die
#!/usr/bin/perl
\$CONFDIR = "/etc/dirvish";
EOF
- cat $f.pl >> $f
- cat loadconfig.pl >> $f
+ cat $f.pl >> $f || die
+ cat loadconfig.pl >> $f || die
done
}
src_install() {
dosbin dirvish dirvish-runall dirvish-expire dirvish-locate
doman dirvish.8 dirvish-runall.8 dirvish-expire.8 dirvish-locate.8 dirvish.conf.5
- dohtml FAQ.html INSTALL RELEASE.html TODO.html
- dodoc CHANGELOG
- insinto /etc/dirvish; doins "${FILESDIR}"/master.conf.example
+ HTML_DOCS=( {FAQ,RELEASE,TODO}.html )
+ einstalldocs
+
+ insinto /etc/dirvish
+ doins "${FILESDIR}"/master.conf.example
}