summaryrefslogtreecommitdiff
path: root/app-backup/dar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /app-backup/dar
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'app-backup/dar')
-rw-r--r--app-backup/dar/Manifest2
-rw-r--r--app-backup/dar/dar-2.7.6.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/app-backup/dar/Manifest b/app-backup/dar/Manifest
index 682074d950a6..d9f1158ce273 100644
--- a/app-backup/dar/Manifest
+++ b/app-backup/dar/Manifest
@@ -1,3 +1,5 @@
DIST dar-2.7.5.tar.gz 2404076 BLAKE2B 2887629cecf069cfb5063132299279b8be985785485c6f04a8389dfd4930f00b073b421fbb17915d69f5efd46ebb4c3d371c10d3936bfb16d82a191218af350d SHA512 a4e01dce8a078ba81b3032a1910d75f0f59a23511246f570a50ade135f49f11e522ed8916a947aece1799dcd1d37308ba6e4a009313b80d6a1561698c3d5623a
+DIST dar-2.7.6.tar.gz 2410200 BLAKE2B 925b4854c66fec9287e0f42d213f94f208b5248d09eb6abe4e36a41df1fc57641d7a6b41e1f8aaa202e6f74ad04399c70a8cb74dc63685985a5671ba54efdf93 SHA512 517fa06a5b8caa53ad111e4287446583f328ee2027169db067610877e05291e63179c1bdd92312a6885d1c7eba0566a86301e974d1d48df56f0fce9ccfdb3a19
EBUILD dar-2.7.5.ebuild 2226 BLAKE2B 305c99ac9f516c706032ec066f7e22d6c85690bc6e7c29cfe8eecd54fbb0a4ca2e2db17fd58edbd0d6de98c3f89af13500e48369a62036f6816880b6f116b3fb SHA512 c43754f566d0ff4772ba9bc8062ac2c121c2d9f9bf7bd85bf1153301b5c06b8e75200e1cbb75708abc19c283c07b40917de85658a42c46bbcedff96155b27092
+EBUILD dar-2.7.6.ebuild 2230 BLAKE2B 7ad96a0246b7db5069e3c93b2ee6b32d711b82e24afc71a48bc3e7a77d18bb215c76e35193bffe3c6c13ff0c66f38e4e6d3d534dcf6774a1a3f040afbcf76223 SHA512 f5efb4de42e27c74f6910d368d18a3284d4d0007c792f1306f3d31ba85bb56edd56aaf64a52cd6a36002d2059c0ee60a50190ce91fe8e78e94e85845cfee6f44
MISC metadata.xml 1284 BLAKE2B b70f06ea13076c3de9470fa1b65d9a17de048db8f52ade94246c62241828be74f308dcc39067b27ed99ff963c3554e371611aba0bb04ed6d57d14d4f7fd7f9dc SHA512 5cbbbff7e0652a85f717f2eb6a574d6fe52d478e049fa81e1c25b1bbe034086d433558952be1bc56ea4492c9c43f6da1e0968cc9132d18e7342890434c0a19d6
diff --git a/app-backup/dar/dar-2.7.6.ebuild b/app-backup/dar/dar-2.7.6.ebuild
new file mode 100644
index 000000000000..ef7cc64225b7
--- /dev/null
+++ b/app-backup/dar/dar-2.7.6.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE="argon2 curl dar32 dar64 doc gcrypt gpg lz4 lzo nls rsync threads xattr"
+
+REQUIRED_USE="?? ( dar32 dar64 )
+ gpg? ( gcrypt )"
+
+RESTRICT="test" # need to be run as root
+
+RDEPEND="
+ app-arch/bzip2:=
+ app-arch/xz-utils
+ app-arch/zstd:=
+ sys-libs/libcap
+ >=sys-libs/zlib-1.2.3:=
+ argon2? ( app-crypt/argon2:= )
+ curl? ( net-misc/curl )
+ gcrypt? (
+ dev-libs/libgcrypt:0=
+ dev-libs/libgpg-error
+ )
+ gpg? ( app-crypt/gpgme:= )
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:2 )
+ nls? ( virtual/libintl )
+ rsync? ( net-libs/librsync:= )
+ threads? ( dev-libs/libthreadar )
+ xattr? ( sys-apps/attr )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ # configure.ac is totally funked up regarding the AC_ARG_ENABLE
+ # logic.
+ # For example "--enable-dar-static" causes configure to DISABLE
+ # static builds of dar.
+ # Do _not_ use $(use_enable) until you have verified that the
+ # logic has been fixed by upstream.
+ local myconf=(
+ --disable-dar-static
+ --disable-python-binding
+ --disable-upx
+ $(usev !argon2 --disable-libargon2-linking)
+ $(usev !curl --disable-libcurl-linking)
+ $(usev dar32 --enable-mode=32)
+ $(usev dar64 --enable-mode=64)
+ $(usev !doc --disable-build-html)
+ $(usev !gcrypt --disable-libgcrypt-linking)
+ $(usev !gpg --disable-gpgme-linking)
+ $(usev !lz4 --disable-liblz4-linking)
+ $(usev !lzo --disable-liblzo2-linking)
+ $(usev !nls --disable-nls)
+ $(usev !rsync --disable-librsync-linking)
+ $(usev !threads --disable-threadar)
+ $(usev !xattr --disable-ea-support)
+ )
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
+
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+
+ # Bug 729150
+ rm "${ED}/usr/share/doc/${PF}/html/samples/MyBackup.sh.tar.gz" || die
+}