summaryrefslogtreecommitdiff
path: root/app-backup/buttersink
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-backup/buttersink
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-backup/buttersink')
-rw-r--r--app-backup/buttersink/Manifest4
-rw-r--r--app-backup/buttersink/buttersink-0.6.8.ebuild47
-rw-r--r--app-backup/buttersink/buttersink-9999.ebuild47
-rw-r--r--app-backup/buttersink/metadata.xml11
4 files changed, 109 insertions, 0 deletions
diff --git a/app-backup/buttersink/Manifest b/app-backup/buttersink/Manifest
new file mode 100644
index 000000000000..415d4d80f00e
--- /dev/null
+++ b/app-backup/buttersink/Manifest
@@ -0,0 +1,4 @@
+DIST buttersink-0.6.8.tar.gz 51784 BLAKE2B 3f18716bcc55aee99bbb73e8a1928c29cb28a782966aded60b019673e0336f342e4d76aff827f9bd7f39713fe9cadcd89f5f81438a86d8867a8b1ac0a57f3957 SHA512 52898140d983bcc6776497504191f0c1c727b24fa9543f5a5997a54ced26301ca492518094ca8770fce8064bc99dc6d3f6760e986eb66f08a758985a7a85ffff
+EBUILD buttersink-0.6.8.ebuild 1238 BLAKE2B 862f8095e60c89caba1e80fbae4e467b79934f9fb83b6f054c33d02bcbc99a5b681ffd0e6b0aaadfc063c8aeda4e9279db526b01a49754701b68c75e4dc6b0c9 SHA512 54096f54a676daf712bcf29c1aaa3310bbd73f142f8ba0af3a222317ce4c18249cdc0c89eb5aa733053188d56f0b48c32a6555fac635ed07b88e1209deadd2ce
+EBUILD buttersink-9999.ebuild 1238 BLAKE2B 862f8095e60c89caba1e80fbae4e467b79934f9fb83b6f054c33d02bcbc99a5b681ffd0e6b0aaadfc063c8aeda4e9279db526b01a49754701b68c75e4dc6b0c9 SHA512 54096f54a676daf712bcf29c1aaa3310bbd73f142f8ba0af3a222317ce4c18249cdc0c89eb5aa733053188d56f0b48c32a6555fac635ed07b88e1209deadd2ce
+MISC metadata.xml 385 BLAKE2B 4baa41b64c2ad94077d2ce5c752c8a42cd4eb54911dfa9c5715c4270530ab7b1648953924b37dfad712e92ffba17c313d5defe9108255abb87b71f7f33814183 SHA512 0a067465c740e3cc79c58e9204024edfadefa0c88ddae3e5cd05776c953388d9493bbe6292cbd0cff739f102993154c970af91b06387424254c8eccdeeee2022
diff --git a/app-backup/buttersink/buttersink-0.6.8.ebuild b/app-backup/buttersink/buttersink-0.6.8.ebuild
new file mode 100644
index 000000000000..998f4d7a31d8
--- /dev/null
+++ b/app-backup/buttersink/buttersink-0.6.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="rsync-like utility for btrfs snapshots"
+HOMEPAGE="https://github.com/AmesCornish/buttersink"
+
+LICENSE="GPL-3"
+SLOT=0
+IUSE="test"
+
+# local tests would require root and cause sandbox issues with btrfs subvolume
+# operations, and network tests would require an SSH server with root login to
+# test the SSH backend, or remote S3 for that backend
+RESTRICT="test"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/AmesCornish/buttersink"
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/AmesCornish/buttersink/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/crcmod[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-fs/btrfs-progs"
+DEPEND="${RDEPEND}
+ test? ( dev-python/flake8[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ if [[ ${PV} == 9999 ]] ; then
+ emake makestamps buttersink/version.py
+ else
+ mkdir makestamps || die
+ echo "version = \"${PV}\"" > buttersink/version.py || die
+ fi
+ distutils-r1_python_prepare_all
+}
diff --git a/app-backup/buttersink/buttersink-9999.ebuild b/app-backup/buttersink/buttersink-9999.ebuild
new file mode 100644
index 000000000000..998f4d7a31d8
--- /dev/null
+++ b/app-backup/buttersink/buttersink-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="rsync-like utility for btrfs snapshots"
+HOMEPAGE="https://github.com/AmesCornish/buttersink"
+
+LICENSE="GPL-3"
+SLOT=0
+IUSE="test"
+
+# local tests would require root and cause sandbox issues with btrfs subvolume
+# operations, and network tests would require an SSH server with root login to
+# test the SSH backend, or remote S3 for that backend
+RESTRICT="test"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/AmesCornish/buttersink"
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/AmesCornish/buttersink/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/crcmod[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-fs/btrfs-progs"
+DEPEND="${RDEPEND}
+ test? ( dev-python/flake8[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ if [[ ${PV} == 9999 ]] ; then
+ emake makestamps buttersink/version.py
+ else
+ mkdir makestamps || die
+ echo "version = \"${PV}\"" > buttersink/version.py || die
+ fi
+ distutils-r1_python_prepare_all
+}
diff --git a/app-backup/buttersink/metadata.xml b/app-backup/buttersink/metadata.xml
new file mode 100644
index 000000000000..d80abca98b5f
--- /dev/null
+++ b/app-backup/buttersink/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>adebeus@gmail.com</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ </maintainer>
+ <longdescription>rsync-like utility for btrfs snapshots</longdescription>
+</pkgmetadata>