summaryrefslogtreecommitdiff
path: root/app-backup/btrbk/btrbk-0.25.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-13 21:03:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-13 21:03:07 +0100
commit8fbd420dce8836e6503b162092e07b6a77a89f1d (patch)
tree071c621ef44d7c1b24a430ac7671d68963b5a4cf /app-backup/btrbk/btrbk-0.25.1-r1.ebuild
parent12d78242dec4f785d0a0bfb1c00eee2d8996c53b (diff)
gentoo resync : 13.10.2017
Diffstat (limited to 'app-backup/btrbk/btrbk-0.25.1-r1.ebuild')
-rw-r--r--app-backup/btrbk/btrbk-0.25.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-backup/btrbk/btrbk-0.25.1-r1.ebuild b/app-backup/btrbk/btrbk-0.25.1-r1.ebuild
new file mode 100644
index 000000000000..10a44f3e7138
--- /dev/null
+++ b/app-backup/btrbk/btrbk-0.25.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://dev.tty0.ch/btrbk.git"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
+HOMEPAGE="https://digint.ch/btrbk/"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+pv"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ net-misc/openssh
+ pv? ( sys-apps/pv )
+ >=sys-fs/btrfs-progs-3.18.2 <sys-fs/btrfs-progs-4.13.2"
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" SYSTEMDDIR="$(systemd_get_systemunitdir)" install
+}