summaryrefslogtreecommitdiff
path: root/app-backup/backintime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-backup/backintime
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-backup/backintime')
-rw-r--r--app-backup/backintime/Manifest4
-rw-r--r--app-backup/backintime/backintime-1.2.0_pre20180221.ebuild88
-rw-r--r--app-backup/backintime/backintime-9999.ebuild87
-rw-r--r--app-backup/backintime/metadata.xml17
4 files changed, 196 insertions, 0 deletions
diff --git a/app-backup/backintime/Manifest b/app-backup/backintime/Manifest
new file mode 100644
index 000000000000..16341a967afe
--- /dev/null
+++ b/app-backup/backintime/Manifest
@@ -0,0 +1,4 @@
+DIST backintime-1.2.0_pre20180221.tar.gz 712330 BLAKE2B 9ba40c5f89b9fbdf0b1c381bf2e3edce13553b2c301792627fc037bd2de181804b2dc6cad6e78a02844f8835dcd6415a35590125e832d55187fa2ed1a5fa864b SHA512 ad1bb11ea411904027952809c577de1a5317f40430af9b91b16a2c157d560c72b65c879bb880b557e9b5e333e76a44977a26486f4ed4f45281a5e8b0d4583c2a
+EBUILD backintime-1.2.0_pre20180221.ebuild 1833 BLAKE2B dd1cb47f69f160df1ea0ae5cb60276001517cbc4647ede66d4bc55351c65012eb105fc63bbac81dd2f3321f90f7f078f75ecfaa07f1f4c9fd550902ecb90e059 SHA512 00f3dbace06bb8609dd14bc1253deb505f63a97685e32fa3ade6c89e226ebd52f7c3b0be97b8713e86f270517eaad284b9298c1b3cb3f90a885a2966ebb21305
+EBUILD backintime-9999.ebuild 1742 BLAKE2B 2f898508c8297374a05f3c5a69bd5cdc1ca306729a1ee79fed8d60d319b2f4ff788a882bc789fd1be6c9a8d61413a84b2b055b55dead2845f68c317960065867 SHA512 acbbee1a19b0c627cfe7268770e1c51d41059c375ed022d94983b530d06f83e5d05f53a189a0a3e844d8baf77fb1df2ef62312e583dcd94245215ae3ae6b2015
+MISC metadata.xml 716 BLAKE2B 469a4318ff5607d74bb1d2166feba52686891921e59c117e15d54057eeafc1d5d3a2c9232e434c3783b04716b8784fcd092bc2d77553e1e56d27939ffb89dd50 SHA512 377471e000a0cb8f034f7c6a20596e48f7fe380c7910f0a97b6a47b779eb466efb6a02b4eef10569a9b9baf7e3eca03d6e22f87e36e4f11836ffb05fa38f7f0a
diff --git a/app-backup/backintime/backintime-1.2.0_pre20180221.ebuild b/app-backup/backintime/backintime-1.2.0_pre20180221.ebuild
new file mode 100644
index 000000000000..1b1e607dc857
--- /dev/null
+++ b/app-backup/backintime/backintime-1.2.0_pre20180221.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+COMMIT=45ec81c185789b2dbafd7348d1af039b5183c9ff
+inherit python-single-r1 gnome2-utils vcs-snapshot
+
+DESCRIPTION="Backup system inspired by TimeVault and FlyBack"
+HOMEPAGE="https://backintime.readthedocs.io/ https://github.com/bit-team/backintime/"
+SRC_URI="https://github.com/bit-team/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="qt5"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ net-misc/openssh
+ net-misc/rsync[xattr,acl]"
+RDEPEND="${DEPEND}
+ qt5? ( dev-python/PyQt5 )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ #fix doc install location
+ sed -e "s:/doc/${PN}-common:/doc/${PF}:g" \
+ -i common/configure || die
+ sed -e "s:/doc/${PN}-qt:/doc/${PF}:g" \
+ -i qt/configure || die
+ sed -e "/addInstallFile \"..\/VERSION/d" \
+ -e "/addInstallFile \"..\/LICENSE/d" \
+ -e "/addInstallFile \"..\/debian\/copyright/d" \
+ -i {qt,common}/configure || die
+
+ if [ -n ${LINGUAS+x} ] ; then
+ cd common/po || die
+ for po in *.po ; do
+ if ! has ${po/.po} ${LINGUAS} ; then
+ rm ${po} || die
+ fi
+ done
+ fi
+
+ default
+}
+
+src_configure() {
+ cd "${S}"/common || die
+ ./configure --python3 --no-fuse-group || die
+ if use qt5 ; then
+ cd "${S}"/qt || die
+ ./configure --python3 || die
+ fi
+}
+
+src_compile() {
+ cd "${S}"/common || die
+ emake
+ if use qt5 ; then
+ cd "${S}"/qt || die
+ emake
+ fi
+}
+
+src_install() {
+ cd "${S}"/common || die
+ emake DESTDIR="${D}" install
+ if use qt5 ; then
+ cd "${S}"/qt || die
+ emake DESTDIR="${D}" install
+ fi
+
+ python_optimize "${D}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-backup/backintime/backintime-9999.ebuild b/app-backup/backintime/backintime-9999.ebuild
new file mode 100644
index 000000000000..9fcb400d83e9
--- /dev/null
+++ b/app-backup/backintime/backintime-9999.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit python-single-r1 gnome2-utils git-r3
+
+DESCRIPTION="Backup system inspired by TimeVault and FlyBack"
+HOMEPAGE="https://backintime.readthedocs.io/ https://github.com/bit-team/backintime/"
+EGIT_REPO_URI="https://github.com/bit-team/backintime/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="qt5"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ net-misc/openssh
+ net-misc/rsync[xattr,acl]"
+RDEPEND="${DEPEND}
+ qt5? ( dev-python/PyQt5 )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ #fix doc install location
+ sed -e "s:/doc/${PN}-common:/doc/${PF}:g" \
+ -i common/configure || die
+ sed -e "s:/doc/${PN}-qt:/doc/${PF}:g" \
+ -i qt/configure || die
+ sed -e "/addInstallFile \"..\/VERSION/d" \
+ -e "/addInstallFile \"..\/LICENSE/d" \
+ -e "/addInstallFile \"..\/debian\/copyright/d" \
+ -i {qt,common}/configure || die
+
+ if [ -n ${LINGUAS+x} ] ; then
+ cd common/po || die
+ for po in *.po ; do
+ if ! has ${po/.po} ${LINGUAS} ; then
+ rm ${po} || die
+ fi
+ done
+ fi
+
+ default
+}
+
+src_configure() {
+ cd "${S}"/common || die
+ ./configure --python3 --no-fuse-group || die
+ if use qt5 ; then
+ cd "${S}"/qt || die
+ ./configure --python3 || die
+ fi
+}
+
+src_compile() {
+ cd "${S}"/common || die
+ emake
+ if use qt5 ; then
+ cd "${S}"/qt || die
+ emake
+ fi
+}
+
+src_install() {
+ cd "${S}"/common || die
+ emake DESTDIR="${D}" install
+ if use qt5 ; then
+ cd "${S}"/qt || die
+ emake DESTDIR="${D}" install
+ fi
+
+ python_optimize "${D}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-backup/backintime/metadata.xml b/app-backup/backintime/metadata.xml
new file mode 100644
index 000000000000..1e5022f0fbce
--- /dev/null
+++ b/app-backup/backintime/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <longdescription lang="en">
+ Back In Time is a simple backup tool for Linux inspired from "flyback project" and "TimeVault". The backup is done by taking snapshots of a specified set of directories.
+ Currently there are two GUI available: Gnome and KDE 4 (&gt;= 4.1).
+
+ All you have to do is configure:
+ * Where to save snapshot
+ * What directories to backup
+ * When backup should be done (manual, every hour, every day, every week, every month)
+ </longdescription>
+</pkgmetadata>