summaryrefslogtreecommitdiff
path: root/app-backup/attic/attic-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-backup/attic/attic-9999.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-backup/attic/attic-9999.ebuild')
-rw-r--r--app-backup/attic/attic-9999.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/app-backup/attic/attic-9999.ebuild b/app-backup/attic/attic-9999.ebuild
deleted file mode 100644
index 7734e651f958..000000000000
--- a/app-backup/attic/attic-9999.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/jborg/attic.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/jborg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Attic is a deduplicating backup program written in Python."
-HOMEPAGE="https://attic-backup.org/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="libressl"
-
-RDEPEND="
- dev-python/msgpack[${PYTHON_USEDEP}]
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- dev-python/llfuse[${PYTHON_USEDEP}]"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- ${RDEPEND}"
-
-python_prepare_all() {
- # allow use of new (renamed) msgpack
- sed -i '/msgpack/d' setup.py || die
- distutils-r1_python_prepare_all
-}